FMOD for Unity // StagingSystem could not be found

Hi FMODders,

I’ve run into an issue upgrading a Unity project using FMOD for Unity. The version leaps are somewhat large; they are as follows:

1.10.09 → 2.02.11

2018.2.13f1 → 2021.3.19f1

The issue I’m facing is within the SetupWizard.cs script. It’s referencing something called StagingSystem on a few lines and Unity is unable to recognize it for some reason. Will attach a screenshot.

I’ve already tried importing FMOD for Unity multiple times to no avail.

Any ideas?


When upgrading the FMOD version in Unity, from 1.10 in particular, there can be some console errors that require some files to be manually moved

Hi Cameron,

Thank you for the tip! I’m working through it now, but the FMOD Event Reference Updater tool doesn’t seem to be functioning normally. When I click “Execute 107 Selected Tasks”, the process runs for a split second and the Unity console throws this error:

“NullReferenceException: Object reference not set to an instance of an object
FMODUnity.EventReferenceUpdater.ExecuteGameObjectTask (FMODUnity.EventReferenceUpdater+Task task, FMODUnity.EventReferenceUpdater+SavePolicy savePolicy) (at Assets/Plugins/FMOD/src/Editor/EventReferenceUpdater.cs:1417)
FMODUnity.EventReferenceUpdater.ExecuteTask (FMODUnity.EventReferenceUpdater+Task task, FMODUnity.EventReferenceUpdater+SavePolicy savePolicy) (at Assets/Plugins/FMOD/src/Editor/EventReferenceUpdater.cs:1377)
FMODUnity.EventReferenceUpdater+d__45.MoveNext () (at Assets/Plugins/FMOD/src/Editor/EventReferenceUpdater.cs:654)
FMODUnity.EventReferenceUpdater.UpdateProcessing () (at Assets/Plugins/FMOD/src/Editor/EventReferenceUpdater.cs:1551)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at /Users/bokken/build/output/unity/unity/Editor/Mono/EditorApplication.cs:35”

Furthermore, every single event in the Updater tool appears to throw the same error when attempting to execute each task one by one.

The steps I took prior to this were:

  1. Open project in Unity; update Unity version
  2. Moved FMOD files as you recommended
  3. Opened FMOD project; followed upgrade prompt
  4. Restart Unity & follow through FMOD Setup Wizard; all successful except Event Reference Updater

Any ideas?


It looks like we missed a file Assets/Editor/FMODMigrationUtil.cs, this will also need to be deleted but that is a different issue to the error you mentioned.

What is the task that it says is required in the updater?
Are you able to share a screenshot of the Event Reference Updater?

Hi Cameron,

Went ahead & deleted the file you mentioned. Attaching screenshots of the Event Reference Updater.


And another:

That all looks normal, I haven’t been able to repro the error but here are the steps I used:

  1. Import new FMOD package.
  2. Close Unity.
  3. Move files from ‘Editor’ folder.
  4. Delete ‘Assets/Editor’ folder.
  5. Open Unity.
  6. Follow prompts to restart Unity and move new libs.
  7. Next step in setup wizard, ‘reorganize plugin files’, process tasks.
  8. Next ‘Update Event References’, process tasks.
  9. Rescan and now no tasks.

Are you able to share your Unity editor log file at all? That may shed some light on what is causing this error.

Hi Cameron,

Finally had a chance to come back to this & actually fixed it!

The reason the Event Reference Updater wasn’t working is because two FMOD-related C# script errors were putting Unity in a locked state. After adjusting the deprecated syntax of triggerCue() to keyOff() in two scripts, the project unlocked and I was able to freely run the Updater.

Thanks for your help & hope this helps someone some day!


1 Like