Using Perforce with FMOD Studio


I’m having a hard time connecting Perforce in FMOD. I know that I’ve filled out all the information correctly (same copy paste from Perforce), however it won’t let me select the client workspace no matter what I do. Anyone else have a similar issue?

Thanks in advance for any help

On Mac 10.15.5
FMOD 2.00.10
Perforce Rev. P4V/MACOSX1015X86_64/2020.2/1999419

Do you get any error messages or warnings? What happens when you try to select the client workspace? Are you setting the perforce settings in the preferences window, or in the “Browse for Project” window?

Hi Joseph thanks for getting back to me

I just got a new error today when I opened FMOD for the first time since original post. I’ll attach a photo that below.

When I have all the info in, there’s an error that pops up (also attached) that just says “No such file or directory” below the “p4v executable” field.

When I try to select the Client workspace, nothing happens. It’s the same result as clicking on a blank part of the screen, no noise, no highlight, etc. as though there were nothing there! Very strange.

I’ve tried in the prefs window and now in the “browse for project” window as well. Both are giving me the same issue in that I can’t select the client workspace.

Thanks again for your help! isn’t the p4 executable, but an application package.

You need to find the p4 command line executable. It should be /usr/local/bin/p4, by default.

If it’s not there, it’s likely you’ll need to download and install the Helix Command-Line Client (P4). It isn’t included in p4v, but has to be downloaded separately.