Win 10 saved FMOD project always crashes when loading on Mac (MacOS 11.7.3)

Project is using FMOD Studio 2.02.07 and works fine on Win 10 system. When I switch to my MBP and try to load it, the application crashes right when it reaches 100% in the load bar. This happens every time.

Using Fork and Github as repository. I never have this issue on the Windows PC.

I tried to delete the Application Support FMOD Studio folder. The issue persists.
Not being able to work on my MBP is a real pain.
Would love some advice :pray:

Can you send us the project which crashes FMOD Studio on Mac please? Please use the Upload section on your Profile page here : Thanks.

Hi Andrew,

Thanks, I will upload it as soon as I can (waiting for project registration approval).

Your registration has been approved. You should be good to upload now.


Uploaded the Mac copy of the project (*minus the git stuff).
I also included a text file with the crash log.

Ok, I’ve got the crash reproducing with your project, thanks for sending it to us. We’ll dive into it and hopefully have some news for you soon.

Much appreciated, thank you.

It looks like your project is crashing due to one of your plugins, I found disabling them (renamed the Plugins directory) allowed the project to load.

Ok, do you know which plugin is causing the issue?

Digging a little deeper I can see it’s coming from libphonon_fmod.dylib, which is the FMOD wrapper for the Steam Audio plugin. I did notice that the actual Steam Audio plugin is missing (which is probably the issue), it should sit next to the FMOD wrapper. Look for libphonon.dylib in the Steam Audio package and include it in the FMOD plugins directory next to libphonon_fmod.dylib.

Thanks Mathew!

I am still having issues to properly open the project on a Mac. Neither spatializer plugins work properly with FMOD on my M1 MBP. I tried to use the Oculus Spatializer V47 and Steam Audio V4.5, followed the setup instructions but the plugins do not open.

I keep getting ‘unknown developer’ warnings on the dylib files when the project opens. Eventually the project does open, but the plugin GUI is not usable, showing the ‘Plug-In Issue Detected’ text on top of it.

I think it could be that the spatializers used do not support apple’s M series processors, only intel 64. We want to try Meta’s more recent V60 spatializer (Meta XR Audio) sometime soon, perhaps it would work well with that version.

I thought their OSP V47 should work on Mac M1 devices though. If you have any ideas as to why I am seeing this behavior please LMK. I will try Meta’s support resources as well.

I appreciate your help!

Usually, plugins that get blocked on the Mac need to be unblocked via System Settings → Privacy & Security, near the bottom the file shows up giving you the option to unblock. You must then reload the application to use it unblocked. Sometimes there are multiple libraries blocked, so you have to repeat the process several times, once for each file.

Beyond that though, both of those spatializers are outside our ability to support, I recommend contacting their support services to find out if they have Apple Silicon included and what range of FMOD Studio versions they have tested with.

We can support the Resonance spatializer plugin if that’s a viable alternative for you as we have full source access and provide our builds of that plugin.