Additional non-asset directory not being added

I just migrated a project from 4.21 to 4.24. I updated the FMOD plugin and made sure the banks are connected. Everything seems fine, but every time I open the project, I am told that I need to “add the non-asset directory to the Copy.”

We use a perforce server so I check out the engine .ini file, click add. I validate. Everything is fine, until I reopen the project.

Any thoughts?

Cheers,

Sterling

All of the FMOD Integration settings are stored in “{ProjectName}/Config/DefaultEngine.ini”, is that the file you are checking out and editing?

Yes, and everytime I open the project, it asks me to do it again, even though I believe the line of code that should be added is already in there.

@cameron-fmod I’m getting the same problem right now, we are using ue4 4.26.1 source and FMODStudio 2.01.09 also we are using p4 as SCM, the problem is when the project has opened show a warning like this:

FMOD has not been added to the "Additional Non-Asset Directories to Copy" list.

Do you want add it now?

We select fix but nothing happens (even outputlog doesn’t show anything) and when we open the project it shows the warning again.

it checkout DefaultEngine.ini but doesn’t write in,

Any Suggest for this? maybe should we write the setting in DefaultEngine.ini?

Are you able to try the ‘validate’ button in the menu before trying the ‘fix’ option again?

Yes I are, but the same issue, it doesn’t modify nothing

Is it possible that the file isn’t being checked out and is not writeable?
image

Are you able to manually edit the packaging settings to add the FMOD bank folder (eg. “FMOD/Desktop”) and have that detected?