DefaulEngine.ini isn't modified by FMOD

We have integrated FMOD to our project but it appears that fmod settings isnt saving even with manually checkout from p4

we are using ue4 4.26.1 source and FMODStudio 2.01.09 also we are using p4 as SCM, the problem is when the project has opened show a warning like this:

FMOD has not been added to the "Additional Non-Asset Directories to Copy" list.

Do you want add it now?

We select fix but nothing happens (even outputlog doesn’t show anything) and when we open the project it shows the warning again.

it checkout DefaultEngine.ini but doesn’t write in,

Any Suggest for this? maybe should we write the setting in DefaultEngine.ini?

Could you describe how you installed the FMOD Unreal integration, and how you submitted your project to Perforce? You must have followed a process that differed from our test cases; if we can work out what the difference was, we may be able to determine the cause of and solution to this problem.