Automation FMOD issues with UE4


We’re currently using Jenkins to automate builds. Today I implemented to build banks in FMOD using command line, before building the game.

However, when it builds banks it probably validates the project and adds “+DirectoriesToAlwaysStageAsNonUFS=(Path=“Content/FMOD/Desktop”)” to the DefaultGame.ini file.

What this results in is this error: “ERROR: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘D:\JenkinsWorkspace\Project_IceBox\Content\Content\FMOD\Desktop’.” when building the game, it duplicated the \Content in the path.

If I remove the “Content” from “Content/FMOD/Desktop” it works, but since it’s automatically generated when building banks, I can’t solve it. How do I solve it?

What versions of FMOD and Unreal are you using? The value of DirectoriesToAlwaysStageAsNonUFS in DefaultGame.ini should be “FMOD/Desktop” in 2.01 and 2.02 so perhaps you could try updating to one of the latest versions and see if that fixes things?

Thank you for the reply,

We’re using version “2.02.04” of the FMOD UE4 Plugin and UE4 4.26.2

I have not been able to reproduce DirectoriesToAlwaysStageAsNonUFS being overwritten every time banks reimport in 2.02.04. Perhaps try changing the value in “Project Settings>Project>Packaging>Additional Non-Asset Directories to Copy” to “FMOD/Desktop”?

I have done that. But when I build banks from command line, it readds Content/FMOD/Desktop to the value.

What is your Bank Output Directory set to in the FMOD Studio Unreal plugin settings? That’s the only other place I can think of that could interfere with the DirectoriesToAlwaysStageAsNonUFS. If it’s set to “Content/FMOD”, can you please try changing it to just “FMOD” and the double check that the “Content/FMOD/Desktop” entry does not exist in the Additional Non-Asset Directories To Copy list?