ADSR not working

Hi there,

Experiencing an issue where applying ADSR’s for use in unreal aren’t applied in game.

I had them working fine in previous versions of F-mod, but in 2.03.00 when testing in game they are not applied - specifically I want a loop to fade out rather than immediately end, whilst testing in F-mod the loop fades out as expected, but in-game the loop cuts to silence immediately.

Thanks in advance for any advice.

Working in unreal 5.4 and with F-mod 2.03.00

  • Joe

Hi,

Can I get you to provide a series of steps that demonstrates how your looping event with AHDSR is set up? Also, the difference in behavior in-game vs Studio is odd, so just to clarify, are you using 2.03.00 for both FMOD Studio and FMOD Unreal?

Hi Leah,

Thanks for the reply. Am I able to upload or link a video as a new member? Trying to do so via this chat box isn’t allowing me to.

In answer to your question, I am using Unreal plugin 2.03.01
And our FMOD project is on 2.03.00

Step by step: I have an event in F-mod. In my Timeline sheet I have an audio track with a file placed on it. That sound is looping via the two looping options found on the single instrument’s deck.

I’ve applied an AHDSR to the master and as expected when I test the sound inside F-mod, the sound fades out via the release time I set when requested. But in game it’s always an immediate stop.

Thanks again for the speed response. If there is anything else I can provide, please let me know.

Joe

Thanks for the repro steps. There’s a known issue with AHDSR that has been fixed with 2.03.02, which we’ve just released - I was able to reproduce your issue with 2.03.00 and 2.03.01, but not with 2.03.02, so I would recommend upgrading both Studio and FMOD for Unreal to 2.03.02 and seeing whether that resolves the issue for you.

If you’re still running into the issue, please upload a video, or your entire project (or a stripped down version where you can reproduce the issue), to your FMOD profile for me to take a closer look at.

1 Like