All Voices Virtualizing - Studio 1.10.11, Unity 2018.3.8

This is an odd error that I’m having trouble diagnosing. I changed next to nothing since the project was last working, aside from adjusting some files and re-building the soundbanks.

It looks like all of my events are occurring as expected, but are immediately being virtualized, resulting in no audible output (see screenshots from Unity and FMOD side).


I’m wondering if FMOD is having issues recognizing the Oculus HMD output (this is a VR project), but the FMOD Listener is where it’s supposed to be.

I’ve tried restarting a few times, thinking it might be a hardware issue, but still getting no audio output. No error messages in the output log, and the more verbose logging isn’t really giving me any clues. The profiler on the FMOD Side shows the events that I would expect, but again they’re immediately being virtualized.

Any advice on what I should try next?


I re-downloaded the repository (team is using Github). Switching to an older commit (when audio was working) does not solve the problem.

However, when I make a build, all of the audio works as expected, which is really strange.

I’m going to work backwards - reinstalling the FMOD Unity Integration first, then the Unity Editor, then Studio if necessary.

If anyone has run into this problem before and has advice, I’d really appreciate it.

SOLVED - A re-install of the Unity Editor seemed to fix it.

For the sake of posterity, I’ll will say there’s a non-zero chance that I had “mute audio” selected in the Unity Game Window. At this point I don’t know for sure.

This is a really easy thing to miss - if you’re having this problem, first do a quick sanity check to see that it is not selected. You might save yourself a few headaches :man_facepalming:


1 Like