Audio volume priority does not work

#1

Has anyone tried to follow the instruction here on how to implement reverb zone in UE4? https://www.fmod.com/resources/documentation-ue4?version=2.0&page=user-guide.html#reverb-zones
I follow everything it said there, but when I have 2 audio volume overlap upon each other with priority 1 for the smallest one and priority 0 for the bigger one, it still plays the reverb snapshot of the bigger one despite I have fully emerged the character in the smaller volume. I tried to change the priority value around and it still happens.

Did I do anything wrong? What could be the problem here? I try to use the same setup but with Unreal Reverb setting and it still works fine so I assume it is not the engine’s fault.

0 Likes

#2

I am able to get it working as expected by following those steps, I’m not sure why it wouldn’t be working.

What version of FMOD and UE4 are you using?

0 Likes

#3

I was using unreal 4.21 and FMOD1.10, I’m not sure where did I do wrong cause apparently the reverb does play, but only the priority of the audio volume doesn’t work.

0 Likes