Skipping FMOD folder for dedicated server


We are building dedicated servers for linux in our UE 4.27.2 game. With our current settings, we end up with an FMOD folder under Content in our staged build that contains all the banks needed by the game client.

Now, we have been removing that from the deploy by ignoring it when we make our docker containers, but it would be better if the linux server build didn’t have that folder to begin with. What is the recommended way to fix this?


This will be because of the ‘Additional Assets to Stage’ settings. Similar to what we do for different platforms, Platform Specifics, you could modify the server config file to exclude the banks from being staged.

Add this to ‘[ProjectName]/Platforms/LinuxServer/Config/LinuxServerGame.ini’
(I think the platform name is LinuxServer)

1 Like

Thanks! The platform is indeed LinuxServer, but I think UE treats it as a desktop build rather than a console platform, so it doesn’t seem to work in the Platforms directory. Instead we were able to get this to work using

Luckily we aren’t doing a linux client config, so this works for us.

1 Like