Bioshock 2 Remaster's Reverb stops when pausing

I am trying to reverse engineer, and potentially fix Bioshock 2 Remastered’s issue with FMOD, where when it goes to the main menu or pulls up the map (basically, switches from 3D rendering, to flash-movie rendering), the reverb dies with it, and won’t come back until you switch level. This usually doesn’t last long, as other things sometimes set it off too like training pop-ups.

I can see in the IAT of Bioshock2HD.exe that it is importing several functions related to reverb from FMOD, and they are:


I can’t find much documentation on these functions, in fact the only mention I even found of them, was getReverbPresetByIndex was mentioned by some guy in a stackoverflow post.

I was wondering, if maybe someone here has familiarity with the version of FMOD they were using to develop Bioshock 2, or maybe has some kind of vauge idea what could be causing this issue? Ideally, we’d just like to block whatever the game is doing to reset the reverb when the menu is opened. I tried putting breakpoints to capture what is calling those IAT functions, but they seem to all be called equally, or some are only called playing, and some are called at the menu.


Good luck with this and let me know if you’ve made any progress!

I figured out the problem was with the engine itself and not FMOD. I made a bytepatch for it here: gir489returns/Bioshock2CrashFix: Fixes crashes with the Bioshock 2 Remaster (

hmm unfortunately I’ve tried installing your patch and I still just get no reverb in the game. Im on windows 11, maybe its a per system fix thats needed