[Bug] Bank load Error on Unity 2021

Hi everyone,

I´m working on a unity Project on version 2021.2.9, and this error appear in console when i try to integrate the FMOD project, i also built the FMOD project and updated all plugins for FMOD (FMOD plugin on Unity and Resonance Audio for unity), also i updated all resonance references on my project, but the real problem is when i play my game on editor and build, the events aren´t called and this error appears
The error:

BankLoadException: [FMOD] Could not load bank ‘Assets/FMOD project/EspaciosConfinados_FmodProject/Build/Desktop/Master.bank’ : ERR_PLUGIN : An unspecified error has been returned from a plugin.
FMODUnity.RuntimeManager.loadedBankRegister (FMODUnity.RuntimeManager+LoadedBank loadedBank, System.String bankPath, System.String bankName, System.Boolean loadSamples, FMOD.RESULT loadResult) (at Assets/Plugins/FMOD/src/RuntimeManager.cs:858)
FMODUnity.RuntimeManager.LoadBank (System.String bankName, System.Boolean loadSamples) (at Assets/Plugins/FMOD/src/RuntimeManager.cs:964)
FMODUnity.RuntimeManager.LoadBanks (FMODUnity.Settings fmodSettings) (at Assets/Plugins/FMOD/src/RuntimeManager.cs:1069)
UnityEngine.Debug:LogException(Exception)
FMODUnity.RuntimeUtils:DebugLogException(Exception) (at Assets/Plugins/FMOD/src/RuntimeUtils.cs:565)
FMODUnity.RuntimeManager:LoadBanks(Settings) (at Assets/Plugins/FMOD/src/RuntimeManager.cs:1076)
FMODUnity.RuntimeManager:Initialize() (at Assets/Plugins/FMOD/src/RuntimeManager.cs:371)
FMODUnity.RuntimeManager:get_Instance() (at Assets/Plugins/FMOD/src/RuntimeManager.cs:163)
FMODUnity.RuntimeManager:get_StudioSystem() (at Assets/Plugins/FMOD/src/RuntimeManager.cs:186)
FMODUnity.RuntimeManager:AddListener(StudioListener) (at Assets/Plugins/FMOD/src/RuntimeManager.cs:438)
FMODUnity.StudioListener:OnEnable() (at Assets/Plugins/FMOD/src/StudioListener.cs:28)

Thanks for help!

Have you added “resonanceaudio” to the Dynamic Plugins List for the Editor platform?

Getting the same error here, for Android.
The project is using Unity 2021.2.12f1 and FMOD 2.02.04. Also, the Banks are manually loaded as AssetBundles.
Had already added ‘resonanceaudio’ -as instructed on the link- to the FMOD Settings, under “Platform Specific” > “Default” > “Dynamic Plugins”.
This seems to work fine on Editor and Window’s builds, where I’m able to run the scene and hear the sounds.

However, I’m seeing this error on the Android build. (Testing on a Oculus Quest 2.)
Banks that do not have Events with a Resonance Audio Source attached seem to load fine, but the ones that do show that error:
[FMOD] Could not load bank ‘BGM’ : ERR_PLUGIN : An unspecified error has been returned from a plugin. at FMODUnity

For testing, I tried removing ‘resonanceaudio’ from the FMOD Settings, and the error I get is different:
[FMOD] Could not load bank ‘Master’ : ERR_PLUGIN_MISSING : A requested output, dsp unit type or codec was not available. at FMODUnity

Also for testing, under “Platform Specific”, tried adding an “Android” platform with same results.

Looking inside the apk, the .so file does seem to be included. (under lib\armeabi-v7a\ )
And changing the “Logging Level” to “Log” doesn’t seem to be giving any extra information.

The test scene of the the Resonance Audio plugin for Unity (without FMOD) seems to be working without issues on Oculus.

Not sure if it’s a bug or if I’m just missing something on the settings, but I’m running out of ideas, so any help would be appreciated!

Hi jeff, yes i add to Dynamic Plugin List and that wasn´t resolve it, right now it , what i´m doing to solve that error, was

reinstall the FMOD resonance plugin for your github page
Add to dynamic plugins in editor and in desktop platform
delete de FMOD.dll on this folder
image

the final step, i build again the FMOD project and re-linked the bank folder
and it works

1 Like

In my case, for Android, the issue turned out to be the same as in this thread:

Updating libresonanceaudio.so to the file included on 2.02.06 and adding libc++_shared.so in the build seems to have solved the issue.