Bug-Complete silence after few runs of games

I have used the latest fmod’s unity integration (1.02.09), but after few runs of the test scene I made, all sounds stopped working and sometimes after few runs without error, I also get null reference error all out of blue. I looked around the codes and through former experience with this kind of problem I assume I ran out of channels. I don’t know why since fmod utilizes channels (real and virtual) the optimum and I haven’t used anything other than 3 events and at most 30 sound effects (even not all of them were played at once). I can upload the fmod project if it helps.
I think (by looking at the code) it has problem with the unity “Play” button, since on the restart of the unity the problem will be solved. Some memory leakage or misplaced garbage collection or destroy functions and such (they are called on program quitting, I saw the code, but maybe not at pause or play/stop).
Thank you for your efforts. I hope it get resolved soon.

Thanks for the report. We’re on xmas break at the moment but I will take a look next week when I’m back in the office.

Thank you Peter! And I wish you a merry Christmas (better late than never :D) and great holidays!
Kudos to all FMod people!

Hi Cunnings,

I have been unable to reproduce this issue. Would you be able to send an email to support@fmod.org so I can get some more details from you?