Runtime Manager continues after ending Unity Playmode?

Hi there,

has anyone found a proper solution for this problem: Error every frame: bind failed 10048

I see, that there is a recommendation to change the port, but that doesn´t seem to solve the initial problem: Something from FMOD seems to stay in the background - even after stopping the PlayerMode in Unity. I tried this in my current project and to as a reference I tried it in the Viking Village. Since I am bound to older versions of FMOD and Unity - these are my specs: FMOD 1.10.19, Unity 5.6.6f2, Win10

Here is a detailed descripton of what happens in the Viking:

  1. After loading the viking village into my empty Unity project, I import the 1.10.19 Package into Unity.

  2. I set my FMOD Settings. Single Platform Build (Banks in Streaming Assets), “Load All Event Data In” disabled, Live Update Enabled on standard port (9264), Debug Overlay Enabled, rest Platform Default.
    3)I create an empty audio object and add the Studio Bank Loader to it. Load on Object Start, Unload on Object Destroy, Preload Sample Data Disabled, Bank added

  3. I add a Studio Event Emitter to the same object. Play Event on Object Start, Stop Event on Object Destroy, everything else unchecked.

  4. I add a listener to the Camera.

  5. Then I start the game in the Unity Player and everything is fine. The audio plays, no errors (just a notification about resampling).

  6. Then I stop the Unity Player and against what I would expect the audio continues to play. That´where things start to become weird.

  7. Next thing: I start the Unity Player again. The audio plays again (it layers up), and I get a bunch of weird error messages. Screenshot: grafik|690x219

  8. Then I stop and restart several more times and get the typical ERR_MEMORY : Not enough memory or resources - Error message.

For one reason or another FMOD continues with its operations after stopping the Unity player. Is there any way to fix this myself? Has anyone figured out a solution? Is there a solution?

Thank you in advance :slight_smile:

By now I have tested myself through all Unity Integrations between 1.10.07 and 1.10.19. The problem starts to occur from 1.10.11 onwards.

It looks like this is a bug in the integration where the FMOD System created by the RuntimeManager is not being destroyed when Play-In-Editor is ended. So each time you press play, a new system will spin up and when you stop the handles to that system will be lost. This will only effect anyone using any version of Unity 5.

This is because the system is trying to initialize with live update enabled, but the previously created system is still alive and using the port that the new one wants to use.

Once you get to eight FMOD systems running at one time, you will encounter this error.

I have just put the fix for this up on our Github: https://github.com/fmod/UnityIntegration/pull/32

1 Like

Thank you for the fix and the detailed explanation cameron-fmod! :slight_smile:

I just tested our project with the two changed files and it works flawless. Have a great weekend. :slight_smile:

1 Like