I would like to give up on fmod for now but i already made some changes in Unity

Hello, I tried to set up fmod but it was a mistake, i don’t understand anything and nothing seems to work as it should, I would like to cancel it for now until a real human can help me irl but I disabled the built in audio in Unity already and now my game doesn’t have sounds anymore and I don’t know how to undo that.
If someone can help me that would be very appreciated because I spend a lot of time and work on that and I just want my game to function normally as before.


The option to re-enable Unity Audio can be found in the Project Settings:

What issues are you encountering, I am happy to provide support to get you up and running and we do have a Unity FMOD Example here: Unity Integration | Integration Tutorial which runs through the whole process of getting FMOD working.

If not, enabling the Unity audio and deleting the Plugins/FMOD from the Unity project and any remaining FMOD components should completely remove FMOD from your project.

I hope you choose to continue to use FMOD.

Actually I don’t wanna give up bc I will evetually need it and gining up just sucks in general but I am so lost, even with the tutorials, I have issues that are not mentioned T^T. For example, I don’t have the example project for the karting microgame. Like in the tuto there is a big orange button thant doesn’t appear on my screen, and I think it is bc it doesn’t find this exemple folder or file (idk what is it). I might have messed up the installation of fmod on my pc, I am not very good with computers.

1 Like


It is good to hear that you want to continue with FMOD.

Can you elaborate or link to the button you are not seeing?

What step of the Unity Integration | Integration Tutorial did you get up to before you got stuck? If you are not following the integration tutorial, what point of the installation process did you get to?

I am happy to walk you through the installation process as much as I can!

It was the 8th step of the 3.2 section of the tutorial, but a friend sent me the folder with the fmod project examples so i guess this part isn’t an issue anymore, however I now have other problems. First one : in the setup wizard window, 1st step, the update event reference appears checked on my window when it shouldn’t, and can’t be unchecked. The rest of the setup wizard seems to be okay, I clicked on close with that one thing checked, and idk if it is bc of that, but the tutoriel says to make sure there is no error Log and I have on that says :
AudioPlayableOutput::OnApplyFMOD : Could not get FMOD system

So idk if I should continue with that


Why shouldn’t it be checked? This is just letting you know the deprecated [FMODUnity.EventRef] is updated to the new FMOD.Studio.EventReference.

To solve this issue:

You have to Disable Unity Audio

Hope this helps!

oh I said that bc it was a setpoint in the integration tutorial, but if it doesn’t have to be then very well.

For the second point, the unity audio was already disabled, for some reason the error log doesn’t show anymore, however the game doesn’t make any sound at all even though I added an fmod listener on the camera and an fmod event emitter on the Arcade Engine Audio as said in the tutorial

oh no i fogot to set the play event to start because apparently I still can’t read even after all those years, my bad

1 Like

it seems to work so far, there is just this message when I pass a ring during the race

Didn’t find audio group for HUDObjective
UnityEngine.Debug:LogWarning (object)
AudioUtility:GetAudioGroup (AudioUtility/AudioGroups) (at Assets/Karting/Scripts/Utilities/AudioUtility.cs:42)
ObjectiveToast:PlaySound (UnityEngine.AudioClip) (at Assets/Karting/Scripts/UI/ObjectiveToast.cs:183)
ObjectiveToast:Update () (at Assets/Karting/Scripts/UI/ObjectiveToast.cs:117)

and the tutorial said to make sure there were no error, this one is a yellow one, is it imortant or willthe tutorial fix this ?

I have an other issue, before I understood why it wasn’t working for me, I changed different things without really knowing what I was doing, and I removed the Arcade Engine Audio Script from the Arcade Engine Audio GameObject, and I just saw that I now need it for the next step of the tutorial T^T

I found the script in the scripts folder, but when I add it again the the Arcade Engine Audio GameObject, some fields are not filled in the inspector

for examples there is no audio sources in the references (idk if is imortant)
is it a problem ?


Good to hear we are making progress!

This looks like there is still a Unity Audio asset trying to play, you may have to look through the project and delete any remaining Unity audio assets.

As they look like Unity audio sources they should not be required, so it should be fine to delete them and remove that script.

Hope this helps!

hello, sorry for the late replie, I think I managed to fix my issues, I still have a lot to learn but thank you for your help :]

1 Like

No worries, if you have more questions please do not hesitate to ask!