BUG: Master bank failed to build according to error message (still builds master bank), missing events

Unreal 4.26.2
FMOD studio and plugin are both 2.01.09

After pressing build, i get an error that says “Failed to build bank ‘Master’ due to the following error: File not found.”

I have verified that the file exists and that unreal is configured correctly, as well as the output directory in the fmod project itself. I also validated the configuration in unreal with the “Validate FMOD” option.

According to another post, this issue may be caused by conv reverb, but that issue was allegedly fixed according to the dev in the post. They also mentioned that clicking Ignore will build without conv reverb.

I tried clicking ignore, and the banks do get built (i deleted the old ones, and fmod studio did output new bank files, which unreal was able to load. However, now some events are not showing up in the editor. These particular event are new, so havent been visible before. Changes to existing events that are visible in the editor are applied after building, but several still do not show up (they are assigned to master bank, but we also tried assigning the problem events to other banks with no success). I’m not sure if the missing events is a separate issue from the error message about a missing file.

It sounds like the missing events aren’t being included in your banks when building. Unfortunately, without more information, it is hard to determine the cause of this issue. Does the “logging” tab of FMOD Studio’s console window display any relevant messages when you try building your banks?

You mention that the missing events are all new. Is it possible that have not been correctly saved or committed to your source control repository?

Do the new, missing events have anything else in common? Specific effects or assets, perhaps?

Hello, thank you for responding. So, i have the logs. There is only one error;

13:01:39 “FMOD_ERROR (18): File not found.”
13:01:39 “FMOD_ERROR f:\jk\workspace\build__2.1__studio_win\studio\src\model\bank.cpp(154): buildBank(this, dataType, absoluteBinaryPath(platform, locale, sBankSuffix(dataType)))”
13:01:39 [Build bank “Master”]: Time taken is 769.74ms

If you’d like the rest of the log, let me know.

For version control, we use SVN, and the FSPRO is on the repo. As far as we can tell, everything is committed correctly. The files we share are Assets, MetaData, Plugins,and the .fspro itself. In the unreal project, we are sharing the full content folder, so all the banks and the generated event files. I’ve tried deleting all the events and the banks, and rebuilding banks again, but even after regenerating the event files, the events are still missing.

As for what is in common, all i’m seeing is spatializer? (I’m not the actual audio guy, so bear with me :-D).

Thanks again for responding, let me know if theres any more info you need.

If you select “File > Validate Project…” in FMOD Studio, does it report any errors or invalidities?

It does not.

Are you able to send us a copy of the project? We may have more luck identifying the cause of this issue if we can inspect it first-hand.