Failed to build bank. File not found. FMOD Studio

Hi guys,

I’ve updated my UE4 project to 4.27 and and as such my FMOD plugin and studio.

I am now on FMOD Studio 2.02.03 up from 2.01.07.

When I attempt to build banks, FMOD Studio errors and says ‘Failed to build bank. File not found’.

Image of Error

According to matthew in the post below, this issue has been fixed as of 2.01.09:

Any thoughts on how I could rectify the issue? The original fix was to remove convolution reverb from the bank, however that is not an option for me at this stage of development.

Thanks heaps!

Further Info:

It appears that if I click the ‘ignore’ button the banks are still (partially?) generated by FMOD Studio.
Build Directory for Banks

In UE4, if I Play in Editor the sounds appear to play. However in my built game the sounds do not play.

I have validated my FMOD Project in Studio and UE4.

FMOD Studio returns no errors with the project.

UE4 states Master.strings does not exist. (Which I presume is related to FMOD not correctly building the banks)
Image UE4 Error

If I roll back to the older versions of the FMOD plugin, UE4 and Studio I can build the banks/ have sounds play in a built game.

Please check that all convolution reverb DSPs in your FMOD Studio project have had an impulse response added to them. Also check the status bar down the bottom in case it says “missing assets”.

Hey Matthew,

Thanks so much for that tip mate.

I didnt have the missing assets statusbar. However I found a couple of old test tracks with conv DSP’s and no impulse. Removing them allows me to build the banks now.

I’ve ran into one other issue.

The built game reports not finding the (And as such has no sound).

[2021.09.20-07.59.52:678][  0]LogFMOD: FFMODStudioModule startup
[2021.09.20-07.59.52:678][  0]LogFMOD: Lib path = '../../../Fiftyone/Plugins/FMODStudio/Binaries'
[2021.09.20-07.59.52:678][  0]LogFMOD: FFMODStudioModule::LoadDll: Loading ../../../Fiftyone/Plugins/FMODStudio/Binaries/Win64/fmodL.dll
[2021.09.20-07.59.52:679][  0]LogFMOD: FFMODStudioModule::LoadDll: Loading ../../../Fiftyone/Plugins/FMODStudio/Binaries/Win64/fmodstudioL.dll
[2021.09.20-07.59.52:680][  0]LogFMOD: Error: Failed to load bank lookup
[2021.09.20-07.59.52:680][  0]LogFMOD: Error: Failed to load asset lookup
[2021.09.20-07.59.52:688][  0]LogFMOD: Default sample rate = 48000
[2021.09.20-07.59.52:688][  0]LogFMOD: System sample rate = 48000
[2021.09.20-07.59.52:688][  0]LogFMOD: Matching system sample rate 48000
[2021.09.20-07.59.52:700][  0]LogFMOD: Warning: Master bank ( not found.

I’m correctly copying the banks using the ‘Aditional Non-Asset Directories to Copy’ feature:
Copy Path

I believe I have the correct settings in the FMOD plugin/Studio Preferences too:
Plugin Settings
Studio Prefs

Anything seem out of the ordinary?

Hey matthew, got a further update.

I was on UE4 Plugin version 2.02.03. Today I noticed today that you guys have released 2.02.03 patch 1.

It in the code changes, the prefix now includes the game directory, might have been the issue I was experiencing

However upon compiling and running this new version, ive got a crash to desktop. Call stack goes through the FMOD plugin. Crash Log Download

Deleting my banks folder (Content/FMOD/Desktop) allowed me to get back into the editor. Building banks in FMOD studio (which tells the plugin to reload in UE4) triggers the crash again.

I think its because the path to assets isnt cleared before the code changes, removing ContentBrowserPrefix entry from DefaultEngine.ini stopped the crash.

Thank you for the extra information- I have reproduced this issue and found that removing the ContentBrowserPrefix entry in DefaultEngine.ini effectively recovers the UE project from a bad state.
For the no sound issue, can you please go into project settings and search for “Additional Non-Asset Directories to Copy”, then remove the exising FMOD array values and add “/Game/FMOD”?

Hey Jeff,

Thanks for getting back to me mate.

Removing the prefix entry in DefaultEngine.ini made the plugin automatically enter /Game/FMOD as the path and everything began working, no issues as of the last two days. So I think that old parameter in DefaultEngine.ini from the old version of the plugin was to blame.

Thanks heaps for your help on the matter guys!