[BUG] Perforce Integration on OSX


(Kyle Rocha) #1

We’re using studio 1.08.02

In OSX Yosemite, When using the Legacy Perforce integration, we are unable to type in a username, the user box is locked out. The integration automatically infers the username from the current user account name which is incorrect. Setting P4User in .profile seems to have no effect.

When using the new perforce integration box is just totally empty, there is now way to do anything with this option selected. Just an empty grey box.


(Thuan Seah Tan) #2

Hi,

Are you using Helix Cloud or are you running the Perforce server?


(Kyle Rocha) #3

We’re running our own local perforce server


(Kyle Rocha) #4

Server version: P4D/NTX64/2015.1/1073410 (2015/06/11)

The message we get back when using the legacy integration is a simple p4 protect access fail message to the effect of.

Access for user ‘foobar’ has not been enabled by ‘p4 protect’.

As for the new integration, it does not appear to report any version control message. Is it necessary to have p4.exe in your path or something on OSX in order to make this work?


(Kyle Rocha) #5

The only output when selecting the new perforce integration is “Macro: Script Callback Action”


(Thuan Seah Tan) #6

Would you be able to provide information regarding the server version? Studio uses the command p4 users to populate the combo box. If it failed, you should be able to see some logging in the logging window of Studio’s Console view.


(Thuan Seah Tan) #7

Do you have the P4USER environment variable set to anything?


(Kyle Rocha) #8

I wouldn’t mind using the P4USER env var. How do you go about setting that in OSX such that fmod studio can access it? Environment variables do not work the same way on *nix systems as they do in windows. You can’t just use p4 set for exmaple.

However, that doesn’t solve the issue that the new p4 integration panel is just blank. I’ve tested it on 2 separate macs now.


(Thuan Seah Tan) #9

Setting P4USER shouldn’t be necessary, but based on your report, it appears Studio picked up a user by the name “foobar” when try to execute the users command.

The behavior of Studio should be similar to running p4 command in a terminal with Studio app location as the current working directory.

As for the new integration, it relies on presence of Perforce command line. So if you can run p4 command in a terminal, then Studio should work too. The only problem I have found so far is due to difference in newline on mac and pc, the script bundled with the installer actually wouldn’t parse the output correctly on Mac. We have a fix for this in the next patch release, but in the meantime, the legacy integration should still be functional.

Wondering if you know anything about the user “foobar”?


(Kyle Rocha) #10

foobar is the username of the local account on the Mac we’re using to test this setup. It appears to be picking that up when the P4USER variable is unavailable.


(Thuan Seah Tan) #11

Hi Kyle,

We have just released 1.08.03 with a few adjustment to the interface. The user combo box should now be editable so if you are unable to find the desired user, you can type it in manually.

As for the new integration, it relies on p4 executable been installed to a location that is reachable via your PATH environment variable. In 1.08.03, we have changed the script so on Mac OSX it will look for p4 executable in /user/local/bin (the default location recommended by Perforce under its installation guide). If the p4 executable is located elsewhere on your machine, you would have to edit the script to point it at the right location.

Studio should provide a warning now if it failed to find the executable instead of just a grey box.


(Kyle Rocha) #12

Awesome, thanks for the update