'BusNotFoundException' (and a few other problems)


So I’m having issues with an FMOD project and I’ll try to not waste any time and go through the events so the problem is easier to locate.

-Built banks and GUID’s and put them in an Unreal project’s folder (plugins folder) but the banks weren’t showing. I could see the ‘FMOD’ folder but nothing in it

-I opened an old Unreal project that had FMOD events in already. The old events and banks were there but adding in the new banks did nothing -still not showing

-I updated Unreal (as I thought it may have been a problem with the Engine’s version) and then got the newest FMOD studio and Unreal integration plugin to make sure everything was up to date

-I swapped out the FMOD folder that goes into the Engine with the new one. When I opened Unreal I got a message saying “‘FMODStudio’ plugin failed to load because ‘FMODStudioOculus’ does not appear to be compatible with the current version of the engine. The plugin may need to be recompiled”

-I decided to open my FMOD project into Unity (thinking the problem was Unreal) and the banks, events, parameter etc all showed but when I pressed play (to test the level) I got an ever expanding list of errors messages, all saying ‘BusNotFoundException’. I’ll put the screenshots of the errors at the bottom

-I got the most up to date Unity integration plugin -still no changes

-I thought it might have been the FMOD project and not the engine so made a new FMOD project with one event going straight to the master bus and put it into Unity -worked perfectly!

That’s where I am now. I wish I hadn’t updated Unreal so I could see if it really was the FMOD project or if Unreal had a problem too by loading a new FMOD project in

FMOD studio and plugins - 1.08.15

Unreal - 4.13.2

Unity - 5.3.5f1

I wish I could fix this myself but I have no clue what the problem is so thought I’d ask before going to Firelight directly

Thank you for reading



With Unreal Engine, the easiest way to make sure the files are all there and in the right place is to open both UE4 and FMOD Studio, then in UE4 go to Help->Validate FMOD. This will point FMOD Studio to the same directory that UE4 is expecting and will build the project. The banks aren’t the thing that shows up in the UE4 editor, but the events and such that are built are.

As for Unity, when you see the “Bus not found”, it’s a good indication that the project settings are invalid. Double check that the right project/build folder is being located.

Thanks for the reply. In Unity, the project has been found correctly. I have no error messages regarding that and I can view all my projects and play them within the event browser. It’s only when I press play do I get that error message (and have no sound).

As for Unreal, I can’t even open Unreal as the FMOD plugin won’t load. It now closes the engine when I get that error message. However, I’ve just changed the plugin to a previous version and all is fine now. It’s just Unity that I can’t figure out.

Sorry about the delay, are you still having this issue?