Cant build for Oculus Quest 2 with Unreal 4.27 and FMOD

The FMOD plugin works on the Unreal editor, but it ives us some error messages when trying to build. This error comes when we have the plugin in our project: Missing precompiled manifest for ‘FMODStudio’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in to override.
PackagingResults: Error: Missing precompiled manifest for ‘FMODStudio’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in to override.

Also using the Plugin in the Engine gives us an error. We just cant build for Android - Oculus Quest 2.

What version of FMOD are you using? Do you have the plugin in the Engine or Project directory? Can you please share the entire log output?

Thank you for your answer Jeff. We are going to add FMOD studio plugin again to replicate and take screenshots. We tried both with the plugin in the engine and in the project. On each case it was a different error message. But we will bring the screenshots later today. We used FMOD studio 2.02.06, and we could connect our project and sounds to Unreal, the music could came out through the editor. We didnt try to make a PC package, but we will try that too.

As in the original post, the error that came when we tried to build was when we placed the plugin in the project only.

Edit: We also are using the 2.02.06 version of the plugin for Unreal.

This is a screenshot WITHOUT the plugin. The build was succesful

This a failed packaging. For this case the plugin was added on the project files.

I couldnt add a second image, but we made sure that the plugin is turned on the plugin manager from the editor.

This is having the plugin added on the Engine Plugin Folders.

Thank you for the logs additional information, and apologies for the delayed response.
There are also errors about missing asset lookup and banks. Can you please tell me the following:

  • Do you have any banks in the “Content/FMOD/Desktop” directory?
  • Did you run the FMOD Validator?
  • Have you added an AndroidGame.ini file as per the Android Platform Specific section of the docs?
  • Are you using any 3rd party plugins in your project, such as Resonance Audio?
    • If so, have you followed the steps in the Android Platform Specific section of the docs to add a “{pluginName}_APL.xml” file?

Hello Jeff. We will run it with the project banks. But our first build tests we did Validated our FMOD project and we could use the banks or listen to them in the editor with no specific comments or unexpected results. Only on the build we find these errors. We tried with the plugin on our project, on our engine and both. We dont have any plugins around audio or that we have checked that create any issues.

Can you please confirm you have added the AndroidGame.ini file as well? This one is important for ensuring banks are packaged correctly.

If you have a C++ project, have you added “FMODStudio” to your PrivateDependencyModuleNames?

Thanks Jeff, we weren´t aware of this steps or requirements. We will follow these steps and reply you about what we find. :slight_smile:

1 Like

Hello @jeff_fmod . I checked the documentation. I created the _APL.xml file, but i couldnt find my AndroidGame.ini file. Is it supposed to be on the files of the plugin or even on my project files? I havent been able to find it or “create it”. Also added “FMODStudio” to PrivateDependencyModuleNames. This is the output (also validated fmod in the project)

@jeff_fmod Hello Jeff, as I understand there should be the “mobile” folder here, to find the AndroidGame.ini file, but there isnt.

Thank you for giving that a shot, here are the steps in more detail:

  1. Go to the root diectory of your project. In this case “IOVR”
  2. Open the “Platforms” directory
  3. Open the “Android” directory
    • If there is no “Android” folder in here, right click inside and select New>Directory, and change the directory name to “Android”
  4. Open the “Config” directory
    • If there is no “Config” folder in here, right click inside and select New>Directory, and change the directory name to “Config”
  5. Right click inside the directory and select New>Text Document, and change the file’s name to “AndroidGame.ini”
  6. Open the newly created “AndroidGame.ini” file in a text editor and add the following lines:
  7. Save and close the file

You will need to build your banks for the mobile platform:

  1. In your FMOD Studio project go to Edit>Preferences>Build
  2. Look in the “Project Platforms” section. If you do not already have a platform configuration called “Mobile” then right click and select Add Platform>Mobile
  3. Close the preferences window and go to File>Build All Platforms

There should be a Mobile subdirectory after this step.

Hello @jeff_fmod thank you for replying. I could add Mobile as a project platform, and the mobile platform did appear. But on my project files i couldnt find a “Platforms” named folder. I will try creating it on the root directory as you mention on the steps.
Maybe this folder thing is because we are on UE 4.27?
This is what we got by creating the platform folder, activating Android platform on the editor (apparently I didnt have it activated on my computer), and adding the mobile platform on the fmod project, building to all paltforms.

I created two pastes just in case, of the log.txt:

The output log from the last build try:

Correct, if any directories/files are missing, just create them. Looking at your log, the error The following directories are set to be staged, but contain restricted folder names ("Desktop"); has now been fixed.

This error is not related to FMOD- but I have come across this before and found that following the steps here worked around the issue: Android Studio error "Installed Build Tools revision 31.0.0 is corrupted" - Stack Overflow

@jeff_fmod Hello Jeff, we could correct our gradle error and create a build without errors. After validating femod we tested our build on Ouclus Quest 2, and it closes the application. We removed the plugin fmod and the fmod content folder and it ran. Would you recomend to try another version of fmod or unreal?

Also, weve found an error about naming the folder desktop, as it has a restriction on the name. We changed the name of the folder and the build worked (we think we might not need that folder four oculus quest as it is a mobile app), and then we found that the app closed as stated in the last reply.

That is unlikely to help, you will need some logging information to determine the cause of the crash. Can you please share a log from the start of the application up until the crash?

This issue is solved by creating the AndroidGame.ini file. Did you create this file?

We could create the AndroidGame.ini file, and as i comment you we could create the build, bit it crashed on platform (OQ2).