UE4.24 Packaged project crashes on Oculus Quest

Hi there, I have been trying to fix this issue for weeks and I’m not sure what else I can do.
FMOD integration works fine in Editor and there are no problems playing the sounds. But when I package the project for android and try to run it on the Quest the app opens, goes black and then crashes. I have redone this with an empty project and as soon as the FMOD plugin is integrated, the app crashes.
I am building out from windows and using FMOD 2.00.08, and there are no errors in the log when I package the project.
Followed the fmod deployment, would really appreciate any advice!

Could you try upgrading to 2.00.10, link with the logging version of FMOD and provide the LogCat output (including the crash stack)?

Hey there, so will try to use 2.00.10, how do I link the logging version of FMOD in unreal?
Ive attachd the logcat crash stack, dunno if you can see something in there that might be going wrong?
crash.log (445.2 KB)

The logging version of FMOD is automatically used for non-shipping configurations in UE4. Looking at the logcat you attached there is some logging from FMOD in there, so however you built and deployed will work.

To help diagnose the crash could you increase the log level to “LEVEL LOG” and run your test again to reproduce the crash? The logging level can be set in the UE4 Project Settings for the FMOD Studio plugin. You can locate it by opening the Project Settings window in UE4 (“Edit” menu -> “Project Settings…”) and typing “Logging Level” into the search box at the top of the window).

Okay I have changed the logging level in the to LEVEL LOG and ran the app again.
Here is the new crash log
I have tried to upgrade to FMOD 2.00.10 but that didn’t seem to work either, app still crashes once in headset
crash.log (431.8 KB)

Thanks for that. Unfortunately the extra level of logging hasn’t added any extra information to aid us in understanding what has gone wrong and so far we’ve been unable to reproduce any issue on Android.

Would you be able to upload the bank files you are using for us to try to reproduce this crash internally? We’d just need your “mobile” platform banks. If you can upload them to your profile page on the FMOD website we can try loading them in a UE4 Android test game.

Okay how to I add it to the profile page? Been having a look and unsure where I’m supposed to be putting it

If you go to https://www.fmod.com and click on “Profile” and then “View Profile” you should see an “Uploads” tab:


Click on that tab and there is a button there to upload files from your PC.

I dont have an uploads tab

Sorry about that, the upload tab only appears for users with registered projects and it looks like your project registration was left pending approval. It’s now been approved and you should be able to access the upload tab.

Thanks! The FMOD project should be up now!

Thanks for uploading your project. I tried to reproduce this crash using your banks but still wasn’t successful. I’ve tried with FMOD 2.00.08 and 2.00.10 using the Oculus Spatializer 16.0.0 and 18.0.0 and loading the mobile banks built using your project without crashing.

Reading back through the thread I notice in your first post you mentioned being able to reproduce this in an empty UE4 project? Would you be able to zip up that repro project and upload it for me to test with?

If possible please include the following files and folders from the UE4 project folder:


Okay so I have the file, but I cant get to the my profile page anymore, as the page doesn’t load up?
I click on profile and the page loads for a second and then goes black!

Is there something wrong with the profile page on fmod? Still can’t get into it!

There appears to have been an issue with our web server which should now be fixed. Would you please try to upload again?

Great! I’ve uploaded the unreal project

Thank you for this, we can now reproduce the issue successfully. We’re investigating now and I’ll post an update when we’ve learned more.

We’ve been able to identify and fix the cause of this crash. The fix will be included in our next release of the FMOD Studio UE4 integration.

We’ve already pushed the fix to GitHub (https://github.com/fmod/ue4integration), so if you’re comfortable grabbing the integration source from there you can get it immediately. The fix is a one line change to FMODStudio/Source/FMODStudio/Private/FMODStudioModule.cpp - you can simply replace that file in our integration with the current version from GitHub and you should be good to go (take care to use the correct GitHub branch though).

Alternatively, it should be possible to work around the issue by changing the “Built bank file separation” setting in your FMOD Studio project to either “Build metadata and assets to separate banks” or “Build metadata, non-streaming assets, and streaming assets to separate banks”. Incidentally, those build options were added at the request of several developers targeting mobile platforms where they are particularly useful in reducing the download sizes of initial downloads and version patches, you might like to investigate those for your project beyond just working around this issue.

Let us know if you are pursuing either of those options and run into any trouble.

Hi Derek,

Thanks for this! So changing the setting in FMOD studio has seemed to work! However can’t seem to get the Oculus spatializer in FMOD to work in unreal! I’ve declared the plugin in the FMOD studio preferences in Unreal but no sound comes out from the editor or build! Any ideas?

I tried building a simple test in UE4 using the FMOD project you sent us previously. I chose one of the events with an Oculus Spatializer in its effect deck and linked it to a trigger in UE4 and that worked fine in Play In Editor and in a packaged build on an Android device.

Are you able to provide any more details about how to reproduce the problem?