Can't find file for asset.

So I was making some good progress with UE4 and FMOD Studio, thanks to Sally’s videos for the most part. Suddenly, after a couple of days of working with no issues, I’m getting a bunch of “can’t find file for asset” errors when opening my project.

I can correct the errors and run the project perfectly. But as soon as I close and reopen the project the errors come back.


When you get these load errors has the plugin loaded correct and can you see all your FMOD event assets displayed in the content window?

To help diagnose what is going on, could you try the following:

  • Create a new UE4 project
  • Copy over your bank files into content\fmod
  • Drag a FMOD event into the scene
  • Save, close and re-open the project.

Does that new fresh project load/save correctly, or does it have the same issue? If its some project-specific issue the next step is to contact We might need to get a copy of the project and see what is going on.

So I created a new project using the Third Person template. I then added the existing FMOD bank files from the older project. I can assign Events to animation blueprints, etc. Everything works fine when save, closing, and reopening.

The other project was the First Person Shooter project from the Unreal Example Game Projects. Even when I create a new instance of that project and create very basic FMOD banks from scratch the problem persists. Should I email


It may be something specific to that game project. We’ll investigate and get back to you.

Hi Geoff,
Did you guys get a chance to look at that project? Thanks!

Hi Eric,
It is on our list but we have not done it yet. Sorry for the delay.

OK. Just to clarify, it’s not the First Person Template, it’s the full-blown First Person Shooter example project from the Learn section of the Unreal Engine Launcher. Thanks again!

Hello Eric,

just saw your post. Have you already tried to check the “FMODStudio.uplugin” in the \Unreal Engine\4.6\Engine\Plugins\FMODStudio folder ?

I think I had once the same issue and I realized that the order of assets loaded for UE4 do have an impact on the FMOD assets. If you havent’t already changed that file, I would recommend you to open it via texteditor and change “LoadingPhase” : “PreDefault” (Default to PreDefault).

Keep in mind to do it everytime a new Version of UE4 (or the FMOD plugin) is coming out, as it will create a new FMOD folder in the UE4 folder.

I hope this helps to get it working properly!


Thanks for the comment. While I couldn’t exactly reproduce the problem you describe, I’ll change the ordering to PreDefault anyway for future releases.

I had exactly the same problem reported by Eric and I’ve solved it following your suggestion.