Some sounds missing in UE4 packaged builds but work fine in the editor

Unreal version: 4.26.1
FMOD version: 2.01.08

So after updating the engine of our game and going from older version of UE to a newer one, we naturally had to update the FMOD plugin/UE4 integration and FMOD Studio itself. Now, we’ve been having this problem for quiet a while now, what basically happens is this:

All of the sounds work while playing the game from the editor, but when packaging the build and creating an .exe file some sounds (that work in the editor) go missing.
I’ve basically tried everything - FMOD plugin validation, additional asset directories to cook in UE4 etc. but none of this works.

What I’ve noticed is that after the update there’s a new folder, besides the one that keeps all of the desktop banks, there’s another FMOD folder with all of the events, banks etc. with .uasset extension.

This folder wasn’t present in the previous UE version we’ve had and what’s more, when I enter this folder, go to the banks folder, and remove all of the banks with .uasset extension, the same sounds that go missing in builds, also start missing in the editor!

So right now, I’m at a complete loss and don’t know what to do anymore. I’m hoping that someone in here has the solution for this. Thanks!

Thanks for reporting this.

The new directories containing uasset files are created by the integration and you should not modify or remove those files - doing so would be expected to cause problems like you encountered. You should be able to restore those uasset files by re-launching the editor, or by choosing “Reload Banks” from the File menu.

I haven’t been able to reproduce any issues with playback failing in a packaged build. If you change the Logging Level setting to LEVEL WARNING and package and run a development build do you see any warning log messages from FMOD?

No warning log messages whatsoever after changing logging level to LEVEL WARNING. Should the .uasset files build into the packaged build aswell? Because for now, ony the conent/FMOD/Desktop and Master.bank file builds, but some of the sounds are still missing. Is there a way (if it’s required to do so) to include the .uasset files in the packaged build?

EDIT: I’ve added the .uasset files to the packaged build via “additional non-asset directories to copy” but to no avail, the sounds are still missing. I’ve tried everything at this point.

There should be no need to worry about the uasset files, just treat them as the other UE4 assets. They’ll be included in the PAK file when you build.

I’m not sure what you mean by “only the content/FMOD/Deskop and Master.bank file builds”? You should have Content/FMOD/Desktop added to “additional non-asset directories to copy” and everything in Content/FMOD/Desktop should be copied to the build, is that not the case?

That is exactly the case, by “only” I meant without the FMOD folder with all of the .uasset files, but as you’ve stated, they’re not needed as they build automatically. The issue still stands, the sounds are still missing and I’m still at a complete loss.

I’m afraid without being able to reproduce this I’m also at a loss to explain it.

Could you package up a minimal UE4 + FMOD Studio project which demonstrates the issue and upload it to fmod.com using the uploads tab in your user profile? If we can test it directly we should be able to figure out what is going wrong.

I’m afraid uploading is not possible in my situation. Right now, the same thing happens in the editor for some of the levels, some sounds are triggering correctly (event FMOD profiler shows that the events trigger) but they output no sound.

We’ve encountered a similar issue where events triggered in code wouldn’t play. One way I found to temporarily “fix” it is by placing the events into the level and turning off “auto activate”.

I wonder if this issue is similar for you!

1 Like

@C418 if you’re in a position to share a repro of this with us we’d love to take a look at it!

We found and fixed a bug which could explain this behavior - the Blueprint functions Find Event By Name and Find Asset By Name are returning null for assets which have not been loaded. We’ve added a fix for this to our upcoming release which.

The fix has already been pushed to GitHub, so if you’re comfortable updating the UE4 plugin source code that way you can access the fix immediately.