Can't find Play In Editor Settings

Hi, I can’t find the Play In Editor Settings in the Unity FMOD setting, where is it exactly? I want to enable live update…


To enable Live Update click on the Editor option under Platform Specific.
Which will then show the options for when in Unity Editor, where you can enable Live Update.

Hope this helps!

Thank you for answer, when I connect, the console shows the following message: [FMOD] LiveUpdate::readPacket : Received init message with incorrect API version: theirs = 0x00020006, ours = 0x00020208
How to fix that?

When connecting FMOD Studio to Unity both sides need to be on the same major version. To solve this you’ll need to update FMOD Studio to a version later than 2.02.xx.

Thanks a lot! updating FMOD studio works, there is another message from the console: [FMOD] SoundSourceInstrumentInstance::startChannelIfReady : Loading delay exceeded, sound may play at incorrect time

Can you help to solve this as well~

No worries,

The error means that too many samples are being loaded in at once.

Are you creating the sound you are playing?

If so, use the FMOD.MODE.CREATESTREAm when you are creating the sound which should resolve the error.

If not, how is the sound getting created/played that is causing this error?

Hope this helps!

Is “FMOD.MODE.CREATESTRE” a line of code I should put into the script?

I am not using a script to trigger the sound, I directly add the FMOD component to play the event in Unity

Yes, if you were creating the sound in a script.

Since you are using the FMOD Studio Event Emitter it is even easier! Enable Preload Sample Data in the Advanced Controls drop-down like so:

And enable Load Bank Sample Data in the Initialization of the FMOD Settings like so:

This will preload the data when the level starts to avoid any delays when playing the event and resolve the error.

*Apologies, the previous solution was for a different error