Can't get 5.1 audio out of FMOD Studio

A bit of info about the setup first. I use onboard realtek audio. I’m using individual audio jacks for sound (Dedicated: Center/Sub, Front L/R, Rear L/R). Everything works well with the 5.1 setup and windows recognizes it as 5.1. All games and movies work correctly.

I’m using FMOD for UE4. My UE4 project correctly relays 5.1 information to all my speakers. I added in an FMOD sound to a car, but the sound only comes from the front (FL, FR, Cent/Sub). Nothing from the rear, even though the sound is literally directly behind the player. The sound doesn’t change direction. Its relayed to the speakers as if its Stereo/Mono. Yes, the game plugin is set to Surround 5.1.

The files I am using are from the FMOD Studio tutorial assets. From the FMOD Studio program, the 3D panner only relays sound to the front speakers. When I pull back the sound origin to the rear, it just downmixes the audio to the front speakers.

My Audio Output Device is set to WASAPI (and I also tried setting it to DirectSound) with my default Device (Speakers Realtek High Definition Audio). It still relays sound to stereo and not 5.1.

I also tried the UE4 Tutorial Project included with the assets. The Surround seems to work, at least the Tornado is making sounds in 3D. But how could my game project be the cause when Surround doesn’t even work in FMOD Studio for me?

What I noticed that might be related to the problem is the fact that FMOD Studio had to Update the FMOD project to the latest version. The FMOD UE4 Project didn’t have to update anything, therefore Surround worked. But now with the latest FMOD, the “Format” setting was removed from the software and now, something might have gotten lost somewhere.

Any help would be greatly appreciated. I’m running on deadlines, so it would be great for some speedy investigations. Especially since I need to see where this problem comes from before we implement into the Xbox One build.


The format is actually still present in the latest version. Instead of a single format for the entire project, you can now specify it on a per platform basis. You will find them in the Build tab of the Preference dialog. By selecting a platform from the Project platforms list, you should be able to inspect its speaker mode.

1 Like

Okay, I just deleted my fmod project and copied a fresh copy of the Tut Assets and now it works…I couldn’t find any differences between the one I had and the fresh copy. Chalk this up to a random unexplained occurrence.