Inquiry about 7.1.4 Output Build in fmod Studio

FMOD output 7.1.4 was added to UE4 manually.

In FMOD studios, there is no ‘surround 7.1.4’ in the Surround speaker mode during the platform-specific build, but if you select ‘surround 7.1’, I wonder if UE4 outputs ‘surround 7.1.4’.

The surround speaker mode is the mode that the spatializer plugin uses by default. Currently the FMOD spatializer does not support surround 7.1.4 which is why it’s not in that list.

You can right click on the Master bus’s output meters in the mixer and select Surround 7.1.4 in the menu to change the output.

Thank you, Richard.

As you said, even if the output meter of the master bus is set to “Surround 7.1.4” in the mixer, 7.1.4 output works in FMOD, but only 7.1 output can be heard in UE4.
(However, all 7.1.4 gauges of FMOD Mixer move.)
What should I do?

We are in the middle of updating Unreal Engine 4 to expose the 7.1.4 option to the FMOD preferences. In the meantime, you will either need to make several changes in the plugin cpp files for this option to appear in the FMOD preferences in UE4, or you can try this branch of the plugin:

Thank you, Richard.

The corresponding cpp file was modified and it was output from UE4.
But what is the reason for the error when packaging?

Could it be a problem because it’s a multi-platform (PC, mobile, console)?

I’m not sure what error you are seeing when packaging, could you post it here for us to look at?

You can use any surround sound with any platform, FMOD will automatically downmix or upmix the output to match the device’s audio device.

Logs like images come out, mobile crashes, and other platforms don’t play sounds.

It’s difficult to tell what is happening from the screenshot. It says something is going wrong with setting the listener attributes, but I’m not sure how changing the surround sound mode could have caused this.

Can you please post the entire log with these errors?