Can't get project to build, "libfmodL.dylib was in manifest but was not produced."


(The Revera Corporation) #1

I’ve also tried the Tutorial and get the same issue.

Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: BUILD FAILED /Volumes/Revera Corp/Projects/WaterPlanet/Binaries/Mac/WaterPlanet.app/Contents/MacOS/libfmodL.dylib was in manifest but was not produced.

I am on Mac

Any guidance would be appreciated, thanks!


(Geoff Carlton) #2

Can you tell me:

  • What version of UE4 are you using?
  • What version of FMOD are you using?
  • Do you have a blueprint-only or code project?

(The Revera Corporation) #3

Hi Geoff,

UE 4.12.3-3013449+++UE4+Release-4.12
FMOD 1.06.06
I’ve tried both as blueprint-only, and code, I have the latest xcode installed

Thanks,


(Geoff Carlton) #4

Thanks, I assume you meant FMOD 1.08.06. I’ll try to repro and let you know.


(Geoff Carlton) #5

I’ve reproduced it. I believe this is the same issue as the PS4 deployment case already reported.

I’ll find out what the ETA is regarding getting the fix into a public 4.12 patch release.


(The Revera Corporation) #6

Thanks Geoff, we are almost ready for beta testing and are waiting for the lead on the project to implement some more general notes/features before we try again.

I was able to strong arm the Tutorial into packaging and running on Mac, but frankly I tried so many things I am not sure what did the trick. I’ll be more methodical if I intent a workaround again and make notes.

Hopefully the issue can be resolved with an update soon so it becomes a non-issue for all of us.

Warm regards,


(Efraim) #7

Same problem here. I’d really love to be able to build the Mac version of the game so we can send it to our backers. PC builds fine. Hope this fix is in soon!

Error on Mac when cooking:

“Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: BUILD FAILED /Users/USER/Desktop/TT3/GAMENAME/Binaries/Mac/GAMENAME.app/Contents/MacOS/libfmodL.dylib was in manifest but was not produced.”


(Efraim) #8

More info on mine: UE4 4.12, Latest FMOD, Blueprint only project


(Efraim) #9

I updated OSX and XCode to the most recent versions also, but the error stays the same.


(The Revera Corporation) #10

Efraim,

We have relegated the task for now as we decided to implement other things first, but in the meantime you can find a tiny bit of additional information here:

https://answers.unrealengine.com/questions/441503/dylib-in-manifest-but-not-produced-mac.html

You may also message us on admin at revera corp fullstop com if you’d like to try and work on it together via email. We got the tutorial to deploy with quite a bit of work but were afraid to mess with our actual project, hopeful for a simple fix.

Best wishes,


(Efraim) #11

Hi! Thanks for the response. I did not find much more info on the link than stated here… also, in my case it isn’t the tutorial I’m trying to build, but our game. Our game doesn’t use any of the tutorial FMOD project.
So for us, it’s a show-stopping bug, not tutorial-related, but FMOD related.

In UE4 development (as well as the Unity beta community that I’ve been part of since 2009) crash-bugs or show-stopping bugs are always prioritized for stability purposes. Always.
In our case we simply cannot build our game which is due to go to our backers.

We’ve contemplated abandoning FMOD and using Unreal’s builtin audio instead.

This will take at least a week so we’re hesitant, but, if this bug has been “relegated for now”, then we have no timing on when this will be fixed.
Which puts us in kind of a hopeless position.

Thanks for the email, I’ll email you right now.

-Efraim


(Efraim) #12

NOTE: Your email address bounced, there is no way for me to reach you privately.


(Efraim) #13

Sorry @Revera Corporation, I thought you represented FMOD. My mistake! Please forget my last message since I wasn’t talking about the tutorial assets, I’ll contact FMOD support directly.


(Geoff Carlton) #14

Sorry for the delay in responding. I’m looking in this now, and it seems like the sanctioned way of deploying .dylibs from plugins just isn’t working on Mac. From trial and error, it appears that some cases work and others don’t. The ones that work are .dylib files that are in the engine directory, and only those referenced from a certain type of module.

I’m hopeful that I can come up with a workaround that will get up and running on Mac, without requiring any changes on the engine side. I’ll update this answer as I know more.


(Geoff Carlton) #15

There was a problem due to a quirk with the plugin system for UE4 Mac, but I’m fairly sure I have a workaround in the latest FMOD 1.08.08 release. It involved having the fmod .dylibs in two different directories, but testing looks good for launching, deploy (development) and deploy (shipping).

Please give that version a try and let me know if it resolves your issues.