"Delay Interval" inconsistency/bug?

#1

Hi,

I’m trying to randomize the delay on a thunder sound before it actually plays. I.e. The lightning visual plays and triggers my Thunder event, and then the instrument delays the actual sound by 300-3000ms. I did this in Designer using the “Trigger Delay” feature (within the Sound Def), but it doesn’t seem to be working consistently in Studio when I use “Delay Interval”.

For my case, I have a parameter called “Random” (set by our game code) that is used to trigger different instrument modules each with their own “Delay Interval” range. When I trigger the event, it can sometimes be fine, but if the event is active and I set the “Random” parameter to a new value, the “Delay Interval” seems to be ignored a lot of the time. I haven’t quite figured out if there’s a consistent pattern.

The Designer-to-Studio project importer translated “Trigger Delay” to “Delay Interval”, so I assume “Delay Interval” is the way to do this.

Thanks,
Sean

0 Likes

#2

I updated my sound card drivers to resolve another issue when using WASAPI with Studio, and it seems like this “Delay Interval” issue is gone. Not sure if it makes any sense that my sound driver would affect this, but I’m happy that it’s working as expected. I’m using an RME HDSP9632.

0 Likes