“DllNotFoundException: fmodstudioL” after upgrading from fmod 1.10.15 to fmod 2.01.11

We wanted to upgrade our project from fmod 1.10.15 to fmod 2.01.11.

This is how we did it.

  1. Removed FMOD completely from the project, removed any helper files named after fmod anywhere in the project, by searching for the name “fmod”.

  2. The existing version of our project had FMOD 1.10.15

  3. Importted FMOD (2.01.11) from the package manager

  4. Imported FMOD build tools from FMOD downloads for the platform-specific settings.

  5. Moved the FMOD bank files that the sound designer gave, to the following address Project/FMODSounds/Desktop/

  6. Added this location to the FMOD settings can be found in FMOD (toolbar) → FMOD Settings or Assets/Plugin/FMOD/Resources/FMODStudioSettings

  7. Now changed the codebase to respond to the newer version of the FMOD(2.0)

  8. Now tried adding the events to already existing FMod events but it cannot find any FMOD events in the project and said “Events not found” in the editor even though the bank files were added to the project

  9. Clicked FMOD (toolbar) → Refresh Banks. Then it showed an error “DllNotFoundException: fmodstudioL”

  10. Then tried to see how the integration has gone so far and clicked the FMOD (toolbar) → About Integration same error posed up “DllNotFoundException: fmodstudioL”

It seemed like integration hasn’t gone well but when taken a build I had no errors whilst building it or whilst playing it but we cannot hear any sound as the events aren’t being set

The issue is apparent, even though the integration is complete and I can see the fmodstudioL under the location in the project it just still senses as missing, maybe if we facilitate the project into finding it, Bank files will get refreshed and we could actually see the events. Project/Assets/Plugins/FMOD/lib/PlatformName/lib/

Please let us know how to fix this issue, thanks :slight_smile:

In this case it sounds like fmodstudioL.dll doesn’t have the import settings required for use in the Editor. To start with, can you please go into FMOD/lib/PlatformName/lib/ and select the offending dll, and makes sure its import settings in the inspector match your current platform? e.g