Driving sounds?


(Maheer) #1

Hello everyone!

I hope someone here is familiar with FMOD studio and Unreal Engine 4 workflow. I’ve been following a video tutorial by the creators and they provided and example Fmod project. Here’s the link, just download the zip file of the project: https://www.fmod.com/download/

Just head over to the integrations tab.

So open the project, go to FMODTute project. Now open the car engine event. Now click play. As you can see, the engine idle clip plays even at 0 rpm and loops.

Now, when you download FMOD and install, an example project is downloaded. If You open that project and open their Car Engine Bank, nothing plays automatically, no idle sound whatsoever. But the individual clip itself is a good idle engine sound. I can’t make that event produce sound without forcibly increasing the RPM parameter. What’s going on?

Is it because the UE4 integrated project was an old version? Because it is. Maybe that’s why it auto plays.


(Cameron Baron) #2

What version of UE4 are you using?
I was able to get it to work in UE4.18, it does not come with the integration so you will either need to have it in the engine directory or add it to the project.


(Maheer) #3

I have 4.18. Apologies but I don’t think you understood my question. You see, the FMOD engine sound bank, provided from the OLD video tutorials, will play an engine idle sound - even with RPM at 0 (which is idea duh). That clip will keep looping until you raise the rpm and then it starts revving.

On the contrary, the example engine bank from the examples project, provided in the latest FMOD studio project, should behave similarly with an idle sound at 0 RPM in its parameter. But this isn’t the case.

If this is too confusing, read my initial post and download the two projects and see what I mean for yourself.

Again, apologies for not making myself too clear.


(Cameron Baron) #4

I’m not having any issues with the Total_Engine or Engine events. They are playing with an idle sound as expected.
Are you getting any errors or warnings in the Output log?


(Maheer) #5

No no, those ones are fine. I’m talking about the “Car Engine” bank from the examples folder that came with the install of FMOD studio. If you press play, an Idle sound doesn’t automatically trigger. BUT if you pressed play in the “Engine” event from The UE4 tutorial folder, it automatically plays an idle sound. Should I provide a video to be more clear?


(Maheer) #6

I think I figured out my solution. On the Unreal Engine 4 Tutorial clip, the autopitch modulation minimum value was set to 0.54. On the examples provided by FMOD, both car engines provided start with a min pitch at 0.0 on their auto pitch


(Cameron Baron) #7

The Engine event from the UE4 example project and the Car engine event in the Studio examples are two different events that have been designed very differently.

The Engine event, from the FMODTute project, has a minimum RPM of 1000. This means that it cannot have zero RPM and will always produce sound.

The Car engine in the Studio example has a minimum or zero RPM, which allows the engine to ‘stop’.