Sometimes events just don't play

Now that it is working, I’m running for into a different issue. Every so often, events just won’t play. Even very simply implemented events. It seems random. Using Studio 2.1, UE4.25.3 and the FMOD 4.25 integration (unfortunately on Catalina for this particular project).

Anyone else experiencing this?

Do you get any error when sounds don’t play?
Is anything else playing at the same time?

I’m afraid not. Just silence. Nothing is muted or anything in Studio when I build my banks. And most of my audio works. It’s just an occasional sound that seems to come over as silence. The events are visible, in the sense that I can see and use them in the editor. I’d say this has happened about one in twenty or so sounds.

I’d suggest connecting the FMOD Studio profiler to your game to diagnose what’s happening. Look at the lifespans view to ensure the Events are triggering, check the levels to ensure they are audible, check voices to ensure they aren’t going virtual.

I have the same problem on occasion and have nailed it down to two problems:
events doesn’t play and/or plays late because they are not even loaded yet.
The other problem is that they are playing but they are inaudible and this is usually solved by fiddling of a spatilizer, some sort of parameter or voice stealing. IF the event is actually not playing and it should it should throw some sort of error-message somewhere, check your message log for any errors and/or warnings.

A playing event in fmod doesn’t need to be audible in order to be “playing”.
Confusing language I know.

Thanks for responding. Nothing in the log to suggest anything is wrong, and they can coexist in levels with other scripted and ambient FMOD sounds that include attenuation. Some of the sounds are even 2D. It hasn’t happened a lot, but it’s happened enough for me to notice. My assets are all proper levels, and I maintain very good gain structure through FMOD. :man_shrugging:

We can’t recall ever seeing a case where events don’t play for no reason. Have you tried @mathew’s suggestion of connecting the profiler to see if that sheds any light on what’s happening?

There are features of the UE4 integration which could play a part in making a playing event inaudible. The Occlusion Parameter, Ambient Volume Parameter and Ambient LPF Parameter settings in the UE4 project settings will automatically drive the values of corresponding FMOD Studio event parameters, which may in turn affect the audibility of events. These effects would occur for 2D as well as 3D events. You should be able to observe any such effects in the profiler.

If the profiler doesn’t reveal anything useful you could try to create a minimal reproduction of the issue by modifying one of our API examples to load and play the same events. It would help to narrow down whether the issue is likely to be related to using FMOD from UE4 and if the issue can be reproduced outside UE4 it is often much quicker to investigate that way.

Is this still an issue for you? If you have any additional information we can investigate further.

Yes it is. On MacOS Catalina, I have tried every recent version of FMOD and their corresponding integrations with every recent version of Unreal, up to 4.25.4. Not only do some events come across as silence, but some events build and never appear at all in the Content/Events folder. I know my build settings are correct.

By the way, I’m not using the Catalina Mac by choice in this particular case. I’m wondering what combination is definitely stable and working fully on that operating system.

Usually what happens is my first event builds as expected. Whether or not it will play is a coin toss. Sometimes it will, sometimes it won’t. This is for the very simplest possible test events with nothing else going on.

If it plays, I feel temporary relief until I make another event in FMOD. From that point forward, no more events make it to the build folder in Unreal. It just shows the first built event. Coinciding with that is the fact that live update stops working, and I lose the ability to control parameters.


Trying to tie this together with the other topic (UE4.25.3 does not work with Fmod integration), it sounds like you’re describing two (possibly related) problems:

  1. Sometimes when building banks in FMOD Studio the FMOD UE4 integration is not reloading the banks and creating the UE4 assets as expected.
  2. Sometimes when playing an event in UE4 using the FMOD UE4 integration the event produces no sound?

Is that right?

Do you have logs from UE4 when either of these problems occur?

In the case of event playback producing no sound, are you able to connect the FMOD Studio profiler and check whether the event instance is being created, or is this only occurring when you’re unable to connect with live update?

I will let you know on Tuesday, which is the next time I’ll be working on that project. Thanks!

What IS working today is UE4.24.3 with FMOD 2.00.15. So far, this is the only combination I can find that works. The 2.1 integrations didn’t work in 4.24.3 or 4.25.4.

I’m going to have to check this on my Windows 10 workstation. I’m wondering if it’s Catalina.

I’ve been testing today with UE4.23.4 and FMOD 2.01.07 on Catalina and I haven’t been able to reproduce either of these problems.

Are you able to provide detailed steps to reproduce both issues (events not being imported correctly when building FMOD banks, and events not playing correctly at runtime)?

I think I’ll make a video. That way you can see exactly what I’m doing. It really isn’t anything special, and can happen even with the simplest possible test events. The complexity of events or logic is definitely not the issue. It can even be a one shot.

Thanks, that should be helpful.

I haven’t made the video yet, but I have some possibly useful information. I just installed the same version of Studio with the same integration on a comparable Windows computer. No problems at all. I’m not doing anything differently on this Mac. I’m starting to be suspicious of Catalina in this situation.

Sorry to take up so much of your time. Thank you for all of the advice so far.


Thanks for the update Ben, we’re more than happy supporting our users with these kinds of issues, and very keen to fix any bugs we can identify. I’m just sorry that we haven’t been able to make any progress on this one. Our own testing on Catalina has never reproduced the issue so we only have your reports to work with so far, and the more information you can provide us the better the chance we’ll be able to work out how to reproduce the issue, or at least identify a potential bug we can fix, so please don’t hesitate to add updates as often as you like!

Today I just wiped everything off of that Mac and started over. Freshly installed UE4, freshly installed FMOD, and so far, everything is working! Yay!

I am so sorry if I’ve wasted anyone’s time on this. I thought I was losing my mind!

I really tried to crash it today, but nope. Smooth sailing throughout. I’ll let you know if anything changes.


Ben Blau

1 Like

Thanks for letting us know Ben, I’m glad it’s working for you now, hopefully forever - it would be nice to have an insight into why it wasn’t working previously but you can’t always get what you want, especially when working with complex technology!

And as I said before, please don’t hesitate to reach out for assistance or feel like it’s a time waster, our products and community benefit greatly from users taking the time to report issues and engage with us in trying to resolve them.

This is still broken and a major issue on Big Sur with UE 4.26.2.

I got this a lot on Windows but usually just a rebuild or reopening UE4 would fix it. But this is not working for me on Mac, it’s just broke