UE4 - FMOD Tutorials - Car engine does not rev as expected

I’ve been following the UE4 - FMOD tutorials (new to integrating these two awesome bits of software) over here https://youtu.be/BI7EwpEIHuY and have learnt so much from FMOD and Sal!
Problem is when I’ve integrated the engine and tried to play the game, it sounds very strange. It’s hard to explain so here’s a quick video explaining what I mean: https://youtu.be/FKOGcsJIJR8

As you can hear it almost sounds like the car is changing gears too frequently or there’s something wrong with the load parameter, in this video my finger was on the W key (forward) for the entire time I was recording the car. I’ve double checked my connections in the blueprints and they match Sal’s exactly.
I’m using UE 4.18 here and FMOD 1.10.03. It did spring to mind that maybe the car functions have been updated in Unreal since the videos were made and maybe that’s causing some kind of problem. I’d love to be able to solve this and figure out how to make the engine sound passable rather than a poor implementation of an engine sound.
I also tried to download to an older version of Unreal but couldn’t find a downloadable version of the FMOD plugin that would work with v4.6 of UE4.

Any ideas?

Testing with the Completed Asset Files in UE4.18 and FMOD 1.10.03, the car sounded fine and did not have any issues.

I would start by comparing the FMOD Studio project you are using to a fresh copy and see if anything has changed. Possibly even do the same with the UE4 project too.

Hi, I did try this initially but thought I’d try again.
Just downloaded the complete assets and ran in UE 4.18 and FMOD 1.10.03 but the car still sounds really odd. The camera on the car is messed up too but I won’t worry about that for now.
Video below showing what it sounds like when trying the completed assets files on their own:

Any other thoughts? I’m still learning towards this being something that’s changed in UE since the assets and blueprints were put together some years ago but I can’t be sure. It doesn’t seem like FMOD is the culprit here but I can’t be the only one who tries this tutorial series and comes up with this end result!

Have you tried opening the Studio project to see how that sounds?
If that sounds fine you could try rebuilding the banks in the game.

Sounds fine in studio, pretty certain there’s something funny going on with UE4 but just no idea what it might be. Tried older versions of UE4 and it’s the same problem. Rebuilding doesn’t seem to solve the issue… totally stumped!