FMOD events will play but wont spawn in UE4


(Christopher fraser) #1

I have sounds within FMOD which I wish to play as a 3D event in UE4, I can drop them in and press play on the sound within UE4 and the FMOD event will play, however when I press to play the level in UE£4 it doesn’t spawn? auto activate is selected and all of the banks are loaded into UE4.

It used to work in my game fine but now it has stopped, anyone got any ideas on why these 3D sounds aren’t working?


(Cameron Baron) #2

Are you getting any errors or logs referring to the banks or events?


(Christopher fraser) #3

LogFMOD: Warning: f:\jk\workspace\1.10_UE4.18_Win64\lowlevel_api\platforms\win\src\fmod_output_wasapi.cpp(531) - Starvation detected in WASAPI output buffer!
LogFMOD: Warning: f:\jk\workspace\1.10_UE4.18_Win64\lowlevel_api\platforms\win\src\fmod_output_wasapi.cpp(531) - Starvation detected in WASAPI output buffer!
LogFMOD: Warning: f:\jk\workspace\1.10_UE4.18_Win64\lowlevel_api\platforms\win\src\fmod_output_wasapi.cpp(531) - Starvation detected in WASAPI output buffer!
LogFMOD: Warning: f:\jk\workspace\1.10_UE4.18_Win64\lowlevel_api\platforms\win\src\fmod_output_wasapi.cpp(531) - Starvation detected in WASAPI output buffer!

All the other output logs seem to be fine


(Cameron Baron) #4

Starvation detected in WASAPI output buffer – This means that the mixer was too slow to output sound briefly. If you are running the UE4 editor it isn’t a big deal since it might well occur if the editor if loading something or exporting, which might cause a CPU spike.

There are a few things you could try:

  1. Manually delete the FMOD folder (inside the project’s content folder) and rebuild the banks in FMOD Studio.
  2. Delete the FMOD UE4 integration and install a fresh copy.
  3. Attach the FMOD Studio Profiler to the playing game, here you should be able to see if any events are actually playing and if any levels are making it to the final output.