Error in Unity Source Control documentation

While using the .gitignore code from the user guide with Unity Collab, the supplied code generates an error.

Error while parsing Collab ignore rule ‘/[Aa]ssets/StreamingAssets/**/*.bank.meta’ at line 40.

Would also like to add following Oculus’s guide on setting up Fmod found here: Install the Oculus Plugin for FMOD Studio Unity Integration: Unity | Oculus Developers

Requires the additional step of moving the imported plugin files into the FMOD/lib/ into the specific folders for android and windows.

That is not documented anywhere and without doing so will cause this error:

SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin ‘OculusSpatializerFMOD’ from ‘PROJECT LOCATION/Assets/Plugins/FMOD/lib/win/X86_64/OculusSpatializerFMOD.dll’ : ERR_FILE_NOTFOUND : File not found.

For both of these errors they appear to be working as intended.

The first error is due to StreamingAssets folder being ignored. If you have nothing in this folder (ie. you haven’t built banks yet or you are using AssetBundles import type settings in FMOD > Settings) then you will get this error. The code does mention if the banks are kept outside of StreamingAssets then you can ignore these ignores.

The second error is, as you have mentioned, because the Oculus plugin needs to be moved into the FMOD/lib/ folder. We can look into incorporating this information into our documentation for a future release.