Unity SourceControl Error

Hi i’m having problem with unity source control. i have no idea what is causing this error. this is .gitignore file i applied

gitignore file :

This .gitignore file should be placed at the root of your Unity project directory

Get latest from gitignore/Unity.gitignore at main · github/gitignore · GitHub


MemoryCaptures can get excessive in size.

They also could contain extremely sensitive data


Recordings can get excessive in size


Uncomment this line if you wish to ignore the asset store tools plugin


Autogenerated Jetbrains Rider plugin


Visual Studio cache directory


Gradle cache directory


Autogenerated VS/MD/Consulo solution and project files


Unity3D generated meta files


Unity3D generated file on crash reports




Crashlytics generated file


Packed Addressables


Temporary auto-generated Android Assets


Never ignore DLLs in the FMOD subfolder.


Don’t ignore images and gizmos used by FMOD in the Unity Editor.

!/[Aa]ssets/Editor Default Resources/FMOD/*

Ignore the Cache folder since it is updated locally.


Ignore bank files in the StreamingAssets folder.


If the source bank files are kept outside of the StreamingAssets folder then these can be ignored.

Log files can be ignored.



Given that you’re importing banks from ./Assets/_FMODBuild, it’s likely that source control has potentially interfered with your built banks somehow. Can you confirm that all of your banks are present in the expected import location? I would also recommend rebuilding them locally to ensure that they’re valid, and seeing whether that resolves the issue.

Could I also get your Unity and FMOD for Unity version numbers, and a screenshot of the Bank Import section of your FMOD for Unity settings?

I fixed it, it wasn’t Source Control issue. it was causing error because there was no output device detected in FMODunity somehow…

Happy to hear you found a solution!

1 Like