Errors running FMOD Studio plus Resonance Audio on arm64 android device

I’m updating an Unity engine android application to support the arm64 platform, and I get the following error whenever I try to play a spacial audio sound using Resonance Audio:

2019-07-16 10:04:53.849 12023-12043/? E/Unity: SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin 'resonanceaudio' from '' : ERR_FILE_NOTFOUND : File not found.
      at FMODUnity.RuntimeManager.CheckInitResult (FMOD.RESULT result, System.String cause) [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.RuntimeManager.LoadPlugins (FMODUnity.Settings fmodSettings) [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.RuntimeManager.Initialize () [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.RuntimeManager.get_Instance () [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.RuntimeManager.get_StudioSystem () [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.RuntimeManager.AddListener (FMODUnity.StudioListener listener) [0x00000] in <00000000000000000000000000000000>:0 
      at FMODUnity.StudioListener.OnEnable () [0x00000] in <00000000000000000000000000000000>:0 
    (Filename: currently not available on il2cpp Line: -1)

I don’t see a 64 bit resonance audio plugin in the arm64-v8a libraries folder. Does one exist? Or is Resonance Audio not supported in 64 builds?

I should mention, I have updated to FMOD Studio 2.00.02, and I’m on Unity 2019.1

Thanks for reporting this, it does appear to be missing from the integration but it does exist. You can find it in the API download for Android at the moment, I will add a task to get this added to the integration.

1 Like

Hi Cameron,

I’m having this same issue but when I copy the file from the Android lib folder, I get a system error that says that “resonanceaudio is damaged and can’t open.” and then it recommends that I trash it.

Is there anywhere else I can get this file to import it into the mac/lib path?

The integration should have a version of the resonance lib for mac in the correct folder.
If it is missing, then you may need to reimport the integration.

Screen Shot 2020-04-02 at 2.18.33 PM

When I go to re-import the FMOD package it doesn’t seem to have the resonanceudio.bundle in the lib/mac/ path, which is where the Unity project is looking to retrieve it. Is it maybe that my old version of FMOD/Unity expected those paths and now you’ve changed where those files exist?

The current package (20008) seems to be placing the resonanceaudio.bundle in the main Plugins folder:
Screen Shot 2020-04-02 at 2.23.37 PM

I deleted that bundle and reimported the FMOD Package and it placed it in the correct folder, but now I get a system error that this resonanceaudio.bundle is damaged and can’t be opened. I’ll try downloading a new package and see if maybe it was just a corrupted download.


Yeah, even after deleting the old resonanceaudio.bundle, downloading a new 20008 FMOD Unity Package, and using the new package to make a new resonanceaudio.bundle, it gives me a system error that says that the resonanceaudio file is broken and needs to be thrown away. Do you know why this could be?


Are you creating a bundle manually?
The integration should include any version of the resonanceaudio plugin you may need.

Nope! I’m just downloading the FMOD 20008 Unity Integration Package and having the resonanceaudio.bundle that it is installing into the file path isn’t working. My system is saying it is broken.

What version of Unity are you using?
When are you getting the error, when you try to play in the editor or when you build a game and try to run it?

I’m running Unity 2019.3.6f1 and it happens when I hit play to run the game in the editor. My Mac system gives me the “resonanceaudio” is broken and should be moved to the trash, and the Unity console gives me errors for the scripts that are referencing events that use the resonance audio plugin.

I haven’t attempted to build the game yet.

Thanks for the information, this is caused by the Catalina gatekeeper and it is something we are working on fixing at the moment.

Okay, thanks! Is it aiming to be fixed in an update soon?

Just checking to see when I can hope to expect to get the project up and running again. Not to be annoying! :stuck_out_tongue:

Thanks again for all of your hard work!!

It looks like this should be fixed for the next release which, at this point, should be available at the beginning of May.

So, aside from the iOS issue I was having before, now I’m having the same issue that buzzrick was having on the Android side of things.

I downloaded the Android FMOD API and copy pasted over the arm64 platform libs as you mention in the accepted answer to this, but I still get the same errors. Am I missing something?

Also, I’m running on Unity 2019.3.6f1 and FMOD 1.10.20.

I saw the new release bulletin but I didn’t see the Android arm64 fix included or the 2.00.02 iOS Catalina gatekeeper fix on the log. Are they coming soon?

Otherwise, if you have any advice on how to fix the arm64 resonance audio issue, me copying and pasting the library included in the FMOD Android API download doesn’t work.

Thanks!! I appreciate your feedback on the issue.

Both of those issues should be fixed in the latest release (1.10, 2.0 & 2.01).

Great! To be clear, do I need to reinstall FMOD Studio 1.10.20 to get this new fix, or just the 1.10.20 Unity Intergration?

Just updating the integration should be all that is required.

Unfortunately that doesn’t seem to be the case. I’ve downloaded the Unity integration for the 1.10.20 version from the website here: .

I deleted the Android FMOD Plugin filepath and completely replaced them with the new integration folder and it still gives me the same error.

“AndroidPlayer(ADB@ SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin ‘resonanceaudio’ from ‘’ : ERR_FILE_NOTFOUND : File not found.”

I’ve tried restarting Unity and rebuilding and still I’m getting this Android error.

Any suggestions?