FMOD, Resonance Audio, Unity, Oculus Quest 2 - Unable to get sound to play on quest 2

Like some other users here, I can’t figure how to make this works…
I’m on Unity 2020.1.17f, I have tested with FMOD for Unity from 2.01.06 to 2.02.07 with appropriate banks, I always have had sound on desktop but nothing on my Quest 2.

Here’s a screen of my settings for the 2.02.07 (where the scene won’t even load on the Quest) :

Thank you for your help

We recently had an issue with Resonance Audio not working on mobile platforms when a particular lib is missing, and this should be resolved in 2.02.08. Please try updating to the latest version of the FMOD Unity integration, and if that still doesn’t work can you please tick Enable API Error Logging, set your Logging Level to “Log”, and post the output of your game’s log here?

Thank you for your answer, I have tested your recommendations : installed FMOD for Unity 2.02.08, loaded the appropriate banks and enabled API Error Logging. Still no sound, and some scenes won’t run correctly.
When I run the app on my Quest, Android Logcat is spamming :
Error Unity SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin ‘resonanceaudio’ from ‘libresonanceaudio.so’ : ERR_FILE_NOTFOUND : File not found.

Thank you for the additional information, is that the only error you are getting? It would helpt to see if there are any other errors appearing before the spamming- would it be possible for you to share your full log from logcat from application launch up until you start getting the ERR_FILE_NOTFOUND?
I know that will be a big log, so you can upload it to your FMOD Profile as a document instead if you prefer.
One more thing, can you please tell me whether you are using Split Application Binaries in your application, and whether you are loading banks asynchronously?

I’m using Async loading like recommended in the documentation (and the logs always send that the banks are indeed loaded), and no Split Application. I’m attaching the logcat of my last test in this message. Before the spamming I spotted this error :
Error Unity [FMOD] FMOD_OS_Library_Load : dlopen failed: library “libc++_shared.so” not found

vk091422_logcat.txt (1.7 MB)

Thanks again for your help !

Thank you for the log- it looks like I got the version wrong and this issue will be resolved in the next release, and is still present in 2.02.08, apologies for misleading you there.
In the meantime you can workaround this issue by manually including libc++_shared.so in your Android build. It should be available in your NDK directory, such as “C:\Android\ndk\sources\cxx-stl\llvm-libc++\libs\armeabi-v7a”, and you just need to drag it into your Unity project and set it to load on startup:


Please give that a shot and let me know if you are still getting any issues.

THANK YOU !

That was it, all works fine now. What a relief… thanks again, cheers !

1 Like