Event don't play on mac


I have PC project integrated with FMod. Everything is working fine but when I open project on Mac events not playing anymore.

Both systems have the right plugin version, I can see and play events in the content browser.
It’s only when I’m playing the game in the editor events don’t kick off.

I’m using blueprint Play node to start the event and that node is definitely used (although Auto-activate don’t work on Mac either).
It just seems that it don’t do anything.

Did anyone encounter such a strange problem?

Try the following:

1.) Run “Validate FMOD” from the UE4 menu and see if it finds any problems.

2.) Look at the log output when you run in PIE and see if there are any warnings or errors.

3.) Check that you haven’t included any plugins in your project that aren’t being loaded. You can tell that by looking at the log when you enter PIE.

4.) If you don’t see anything that could be wrong, then you can contact support@fmod.com and provide the log, and we can look into it.

Thank you,

After checking log output I found that it’s because Oculus Spatialiser plugin is not started on Mac and all FMod events are using it.
I was looking through the documentation but didn’t find anything about using that plugin on Mac.
Is it currently supported on that platform (we need it just for editor)?

Yes, it should be supported, but you will need to drop in the mac .dylib into the FMODStudio/Binaries/Mac directory, and enable the Oculus Spatialiser from the settings menu. Please try that and let me know if it works for you.

The file you mentioned is UE4Editor-FMODStudioOculus.dylib that is in the mac version of the plugin?
In that case it is there all the time and plugin is enabled.

The oculus plugin is called libovrfmod.dylib, you can get it from the Oculus AudioSDK.

The file wasn’t there before but after copying it to FMod/Binaries/Mac folder FMod events are still not playing.
I’m geting warning in the output log:
LogFMOD:Warning: /Users/fmod/jenkins/workspace/Build__1.8__UE4Libs_Mac/studio_api/src/fmod_effect.cpp(188) - Missing DSP plugin ‘OCULUS SPATIALIZER’
LogFMOD:Warning: /Users/fmod/jenkins/workspace/Build__1.8__UE4Libs_Mac/studio_api/src/fmod_bankmodel.cpp(238) - Creating stub DSP plugin model and continuing.
LogFMOD:Warning: /Users/fmod/

Note that our UE4 integration doesn’t attempt to load plugins in the editor until you run PIE, so those warnings might not mean anything. That is done to try to keep maximum stability for the editor regardless of what the plugin is doing.

If you aren’t hearing anything in PIE, you can contact support@fmod.com and provide an output log. We’ll see if there are obvious warnings or errors.

Problem solved.
I had to link libovrfmod.dylib in Project settings -> FMod studio -> Advanced -> Plugin Files
as ovrfmod not libovrfmod.
I got it wrong because of the filename.

Thanks for help!