Sound Occlusion Not Working Again


#1

Hi,

I’m having an issue right now that I don’t know why it can be happening. Last year I posted a question in the forums in which I said that the occlusion setting in the UE4 wasn’t working and I tried with both options: 1. Setting the property “Occlusion” : “1” on the event and adding the LPF so I can change those values inside the engine or 2. Set the parameter named “Occlusion” and automating the LPF.

The solution provided at the moment was to change the version from 1.10.09 to 1.10.10 which is the one I’m currently using but again the occlusion is not working anymore. I tried once more both options and neither worked. The only thing that I added in the events was the Distance Filter plugin and also set it on the engine as suggested on the API documentation, don’t know if that might be the problem or if it is definitely something else that I don’t know.

Either the case might be, I’ll really appreciate the help you can provide on this matter, I’m close to a deadline and I can’t see what the real issue is. Thank you very much for your attention and I’ll look forward for your reply.

Andrés


#2

As I’m working on occlusion as well at the moment, I just tried to replicate your settings. Both of your described methods are working perfectly fine.

However, once I add the “Distance Filter” effect, my event goes completely silent and I won’t hear anything. So maybe the effect is the problem and won’t work in conjunction with the Unreal controlled occlusion?


#3

Thanks for your reply first off. In my case the events don’t go silent, they still playback and the distance filter works fine, the occlusion doesn’t. It is still weird and I still figuring out why or what may be the cause.


#4

Have you just tried removing the “Distance Filter” effect? If this resolves your problem with the occlusion you could just replace the “Distance Filter” with the build in distance parameter automating a lowpass filter. It should just work the same.