"EventNotFoundException: FMOD Studio event not found 'event....'" in build

Hi! In the Unity editor the sound works as usual but when I run a build of the game it crashes and I get this error:

“EventNotFoundException: FMOD Studio event not found ‘event…’”

The “StreamingAssets” folder has been copied to the build data folder and the “Master Bank.bank” and “Master Bank.strings.bank” is inside it.

Help with this would be much appreciated!


The issue seems to be that it doesn’t copy over the newest banks to the build folder. Because the size of the Master Bank in the project is 669 kB but in the build it is only 22 kB.

We’re using Perforce as source control and that seems to be the problem. First I thought it was because the files were not checked out, but now I tried to check them out but it still can’t copy the files to the build folder.

In the editor we’re getting this error:

UnauthorizedAccessException: Access to the path “FMODAssets\Desktop//Master Bank.strings.bank” or “D:/PerforceGameProject3/2018_GP3_Team_1/GameProject3/Assets/StreamingAssets/Master Bank.strings.bank” is denied.

1 Like

Are the banks, in the source directory, marked as read only?

No they are not.

Could you try:

  • deleting the StreamingAssets folder competely
  • deleting the Studio build folder completely
  • rebuild Studio
  • see if the integration copies the banks over

If this does not help, can you tell me the integration version you are using?

1 Like

Deleting and rebuilding worked, thanks a lot Cameron!

Are the banks being loaded before you are trying to use the event?
Are you getting any other errors or warnings?

Thanks for the response, see update above.

Thanks a lot Cameron.
you saved US :wink:

@cameron-fmod and @CamperDude3000 : I’m having the same problem, could you explain how I do this, I’m not sure what it actually means? :slight_smile:

Thank you!

Hi @deHaan! There should be a folder called “StreamingAssets” directly under the “Assets” root folder in Unity. Delete the banks in that folder, and after that rebuild the banks from FMOD Studio.

Then make sure the banks appear again in that folder, build your game and hopefully it will work! :slightly_smiling_face:

Why this happens in the first place though, I have no idea.

1 Like

@cameron-fmod How do I check this? I’m not an experienced programmer :frowning:
I copied my project to another computer, reassigned the bank, but it still says it can’t find the event. I tried deleting and rebuilding as you suggested, it didn’t help. Formally everything is fine, FMOD project is fine, no other errors in Unity. The paths are correct. Everything worked fine on the first machine.

Unity 2018.3.12f1
FMOD 1.10.10

You could check in code by using FMODUnity.RuntimeManager.HasBankLoaded("bank:/bankName");, otherwise if you change the ‘Logging Level’ in the FMOD Unity settings you will get a lot more information in the Unity Console.