Failed to load FMOD UE5.1

I’m having issues with getting FMOD to run in UE5.1. I did several reinstalls, added it to blank projects, imported the data, … at some point it always stops working. And the main issue seems to be a Json failure. I get variations of this text:

Failed to read file. Invalid Json Token. Line: 1 Ch: 1
…/Project/Plugins/FMODStudio/._FMODStudio.uplugin

The thing is, I was able to get the engine to recognize the plugin in some cases, so that it plays in engine. But as soon as I try to package the game I get this error message. I’m working mainly on a Mac with the latest OS installed. I also tried to switch to windows, but the issue remains. Here the error often is displayed from the get go, so that I can’t open the project at all (I tried FMOD2.02.11 for Win and Mac respectively).

Any help here would be appreciated.

Hi,

Could you please post the contents of your FMODStudio.uplugin? Can you also confirm the filename of the FMODStudio.uplugin file?

I left the plugin unchanged. So the original name is “FMODStudio.uplugin”. The plugin name that causes trouble is not visible in the regular file browser. I was able to see it when I opened the folder in Xcode/Visual Studio, but couldn’t access it afaik.

{
    "FileVersion" : 3,
	
	"FriendlyName" : "FMOD Studio Integration",
	"Version" : 20211,
	"VersionName" : "2.02.11",
	"CreatedBy" : "Firelight Technologies",
	"CreatedByURL" : "http://fmod.com",
	"Description" : "FMOD Studio Integration.",
	"Category" : "Audio",
	"EnabledByDefault" : true,

	"Modules": [
		{
			"Name": "FMODStudio",
			"Type": "Runtime",
			"LoadingPhase": "PreDefault"
		},
		{
			"Name": "FMODStudioEditor",
			"Type": "Editor",
			"LoadingPhase": "Default"
		}
	],

	"CanContainContent" : true,
	"Installed" : true
}

It sounds like you might be running into the same issue as this user: Packaging for Mac - JSON Parse Exception FMODStudio.uplugin - #3 by jmccormicksae.

Could you try cleaning up any hidden files containing the ._ in their paths that might be causing issues?

1 Like

Seems this does the trick. Thank you : )

1 Like