FMODstudio for Unreal 5.2 not installing properly

I am on MacOS Ventura 13.5
I am having an issue trying to integrate the FMODstudio plugin to Unreal 5.2.1.
If I load up my project, drag the FMODstudio plugin to the correct plugin location in the directory it will pop up within my project fine.

Then it prompts me to restart the program. Upon reloading it crashes trying to load the plugin.
Not sure where it’s going wrong.


Unfortunately, I was unable to reproduce the crash. Can I confirm that it is a C++ project and not a blueprint only? Could you please try adding the plugin files while the project is not running and try relaunching the project? If it is a C++ project could you also try running it from the XCode workspace and see the there are any errors as it may need to recompile some FMOD files?

Hope this helps!

Hey Connor,
Thanks for the reply. Unfortunately it is a blueprint project. I’ve tried bringing in the FMOD plug-in while the project isn’t running and get the same result.

FMOD won’t work with Blueprint-only projects: Unreal Integration | Troubleshooting - Blueprint-only projects. As suggested in the docs, could you add a black C++ class to the project which will change the project to include C++. This can be found under the Tools dropdown in the Unreal Editor:

Once it has added the class it will also create a .xcwrockspace which will require XCode 14 (App store - XCode), open and run this to recompile the FMOD integration.

Hope this helps!

1 Like

Thank you @Connor_FMOD and to @Tynituck for bringing this issue to the forum. I am in the same situation. I note that this combination actually works: UE (5.1.1) + FMOD (2.02.16). What happened between UE (5.1.1) and UE (5.2.XX) ?

I have not tried the solution of @Connor_FMOD, yet, but will try it, this weekend.

Question: Will your solution work if I choose to install UE-integration plug-ins in the /Engine folder (path below), instead of having to copy the same UE-integration plug-ins folder into EVERY UE project folder?

/Users/Shared/Epic\ Games/UE_5.2/Engine/Plugins

: )

Thank you!! I deleted reinstalled everything and this solution worked for me, must’ve missed that detail somewhere. Thanks for the reference!

1 Like

Hello @Connor_FMOD

Although I am getting a similar error message (see attachment), I think I am dealing with another issue. I can’t even implement your solution. After saving the UE-integration folder to the correct location, UE Editor refuses to launch and so, I am not even given the chance to set up a blank C++ class. As I wrote, UE (5.1.1) + FMOD (2.02.16) works fine. So, I might have to stay with this version until a fix presents itself



With 5.2 can I confirm that:

  1. The project is not Blueprint only
  2. You launched the project from the XCode and rebuilt FMOD Studio before trying to open UE5
  3. Is there anything you are doing differently with 5.1?


Thanks @Connor_FMOD,

I believe my issue is not related to any specific C++ or Blueprints-only project. As you probably know, “The FMODStudio plugin can be placed in the Engine/Plugins directory, or in your game's GameName/Plugins directory.” My preference is to install “FMODStudio plugin can be placed in the Engine/Plugins directory”. Thus, the error I get comes form merely trying to launch UE 5.2 from Epic Games – before I even create any project. By the way, I have also tried the 2nd method of installation: “your game's GameName/Plugins directory”. Solutions (?) that I see other users suggesting is simply a complete erase and re-install of all Unreal Engine components.
For information:
Macbook Pro with Apple M2 Max processor
macOS 13.3
Xcode 14.3.1

: )

1 Like


Unfortunately, I wasn’t able to reproduce the issue.

I have the 2.02.16 integration here:

and Unreal Editor launched without issue.
Could you please check in your Privacy & Security Preferences that any files related to the integration are allowed to run?

Are you running, precisely, the same set-up?
Macbook Pro with Apple M2 Max processor
macOS 13.3
Xcode 14.3.1


I’ve done my best to confirm Privacy & Security Preferences are set correctly and that all files related to the integration are accessible – I’ll keep looking into how to do this. I have two main options: (1) in macOS 13, you can give, for example, full disk access to an app ; and (2) command line.

How are you with UE crash reports?

For example, if I save the UE-integration plug-in to an actual game project (/Plugins folder ) – instead of the /Engine/Plugins directory, I can, at least, launch the UE Editor. Then, the game project fails, but UE Editor gives me this crash report (see below).

Next, I think I’m going to do a thorough erase and re-install of all Epic software. I’ll pay close attention to Privacy & Security Preferences - Apple now calls them “settings”, not "preferences


Crash report


Assertion failed: Pair != nullptr [File:Runtime/Core/Public/Containers/Map.h] [Line: 643]

UE::Core::Private::Function::TFunctionRefCaller<FTurnkeySupportModule::UpdateSdkInfoForDevices(TArray<FString, TSizedDefaultAllocator<32>>)::$_12::operator()(int) const::'lambda'(), void ()>::Call(void*) Address = 0x2a7804774 (filename not found) [in UnrealEditor-TurnkeySupport.dylib]
TGraphTask<FAsyncGraphTask>::ExecuteTask(TArray<FBaseGraphTask*, TSizedDefaultAllocator<32>>&, ENamedThreads::Type, bool) Address = 0x105a1c590 (filename not found) [in UnrealEditor-Core.dylib]
FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x1059fdbbc (filename not found) [in UnrealEditor-Core.dylib]
FNamedTaskThread::ProcessTasksUntilIdle(int) Address = 0x1059fbf48 (filename not found) [in UnrealEditor-Core.dylib]
FTaskGraphCompatibilityImplementation::ProcessThreadUntilIdle(ENamedThreads::Type) Address = 0x1059fa218 (filename not found) [in UnrealEditor-Core.dylib]
FlushRenderingCommands() Address = 0x10392057c (filename not found) [in UnrealEditor-RenderCore.dylib]
FSlateRHIResourceManager::~FSlateRHIResourceManager() Address = 0x131c1ef48 (filename not found) [in UnrealEditor-SlateRHIRenderer.dylib]
FSlateRHIResourceManager::~FSlateRHIResourceManager() Address = 0x131c1ff3c (filename not found) [in UnrealEditor-SlateRHIRenderer.dylib]
FSlateRHIRendererModule::~FSlateRHIRendererModule() Address = 0x131c3bcc0 (filename not found) [in UnrealEditor-SlateRHIRenderer.dylib]
FModuleManager::UnloadModule(FName, bool) Address = 0x105e1ef80 (filename not found) [in UnrealEditor-Core.dylib]
FModuleManager::UnloadModulesAtShutdown() Address = 0x105e1f7bc (filename not found) [in UnrealEditor-Core.dylib]
FEngineLoop::Exit() Address = 0x10224c2c8 (filename not found) [in UnrealEditor]
GuardedMain(char16_t const*) Address = 0x10224c780 (filename not found) [in UnrealEditor]
-[UEAppDelegate runGameThread:] Address = 0x102267cd0 (filename not found) [in UnrealEditor]
-[FCocoaGameThread main] Address = 0x105ca93d8 (filename not found) [in UnrealEditor-Core.dylib]
Unknown() Address = 0x18f34263c (filename not found) [in Foundation]
Unknown() Address = 0x18e2f3fa8 (filename not found) [in libsystem_pthread.dylib]
Unknown() Address = 0x18e2eeda0 (filename not found) [in libsystem_pthread.dylib]


Unfortunately, we do not have that exact device.

If it is possible could you please try the following.

  1. Remove any FMOD files from the UE engine plugins directory (Users/Shares/EpicGames/UE_5.2)
  2. Create a new C++ UE project
  3. Close the project once it has been created
  4. Add the FMOD integration files to the project (MyProject/Plugins/FMODStudio)
  5. Open the ProjectName.xcworkspace in XCode 14 do not open the ProjectName.uproject
  6. Run the project from XCode
  7. Once it has successfully launched once again close the project and exit XCode
  8. Move the FMOD integration files to the engine plugin directory (Users/Shares/EpicGames/UE_5.2)
  9. Try to launch the project from the ProjectName.uproject file.

Let me know if that has any effect.

This sounds like the above issue where the integration just needs to be recompiled in XCode for it to work.

In regards to the UE crash log, the main error I see is File Not Found which doesn’t seem to be our problem as it is having trouble loading the plugin rather than finding it.

Thank you for the note about the change to the system settings name :slight_smile:

Thanks @Connor_FMOD .

Issue resolved!

Integration needed to be recompiled in XCode – this was a first, for me, as I use Blueprints (I know some CSound, but no C++). For your information, before following your instructions, I also tried launching UE Editor with the latest FMOD release (2.02.17). The latest version resulted in the same error message as 2.02.16. Do you foresee Firelight dealing with this issue in future iterations?

: )

1 Like


The issue is the mismatch in the version the integration is being built against. The integration on the downloads page is built again UE 5.2.0 while you are trying to use 5.2.1 which is why it needs to recompile. We have noted this issue and are looking at solutions.

Thank you for bringing this to our attention.

1 Like

Has this problem been resolved as I’m still trying to run fmod plugin in 5.2.1 ?


A solution may be compiling the integration for 5.2 from our GitHub repository here: GitHub - fmod/fmod-for-unreal at 2.02-UE5.2. Instructions for recompiling the plugin can be found here: Unreal Integration | User Guide - Compiling the plugin.

Hope this helps!