Fmod atmos settings

We want to use Dolby atmos by utilizing fmod.
However, the fmod preferences build setting does not show surround 7.1.4 mode.

I bought a Dolby atmos license, but what else do I need to do?
The engine is unreal4.

Right-click on the meters of the master output bus in the mixer. In FMOD, there are usually lots of context-sensitive goodies hiding under right-click!

The mixer section of the manual will probably have some other applicable info for you too, regarding multi-channel stuff.
https://fmod.com/resources/documentation-studio?version=2.1&page=mixing.html

The master output was applied to surround 7.1.4.
Should the platform surround speaker mode be “Surround 7.1”?

It may not matter, depending on your project.

The platform surround speaker mode defines the default format of the master bus output and the channel format of effects that automatically set the channel format at their position (such as the FMOD spatializer effect), and has no other effect. As a result, if you are setting the output format of the project master bus manually, and using plug-in effects that support Atmos and the 7.1.4 channel format instead of FMOD’s built-in spatializer effect, platform channel format should have no effect on your project.

On the other hand, if your project contains some content in a channel format other than 7.1.4, then you should set your project channel format to a format that matches that content.

Thank you for your answer.
Please check if what I understand is correct.
If I use the “3D Object Spatializer”, is it OK to set the Surround speaker mode to “surround 7.1”?
(Unreal Engine 4 has an FMOD output setting of Surrond 7.1.)

Additionally, I would like to print out 2D sound as Surround 7.1.4 output, do I need to change the output manually?
(Or is it possible to change the fmod output setting of Unreal Engine 4 to surrun 7.1.4 as a separate method?)

(The master bus’s output is Surround 7.1.4 and the event is set to Stereo or 7.1 output or 7.1.4 output as required.)

Yes, it is OK.
The Object Satializer does not output in the 7.1.4 channel format, but its signal will be automatically upmixed to match the output format of your game, as I describe below.

No, you do not need to change to output format manually.
If the output channel format of an event, track, or bus does not match that of a track or bus into which it is routed, the FMOD engine automatically upmixes or downmixes the signal to match the channel format of the track or bus into which it is routed. In the case of upmixing from 7.1 to 7.1.4, this generally means the four additional channels will receive no input from the event, track, or bus that’s outputting in 7.1 format. This does not interfere with their ability to receive and mix input from other events, tracks, and buses whose outputs are in 7.1.4 format.

I’m not sure what you mean by this.

If you look at the FMOD studio setting in the Unreal Engine 4 project setting, you can set the output format, is it necessary to take additional measures to change it to surround 7.1.4?
(It is currently set to surround 7.1.)

It’s not necessary to change the UE4 audio output format, but you should change the FMOD output format in UE4 to match the output format of your FMOD Studio project.

If the master output of FMOD is 7.1.4, then should I change the FMOD Output of UE4 to 7.1.4?

I am inquiring because 7.1.4 of the FMOD output method of UE4 is not visible.

Yes.

I’m afraid I’m not quite sure what you mean by this.

image
I can’t see it.

Ah, my apologies. There was a slight miscommunication between myself and one of our developers.

As of the time of writing (April of 2021), we do not yet support 7.1.4 output mode in UE4. We’ll add this feature in an upcoming version of the FMOD Studio UE4 integration.

1 Like

Can you tell me when it’s planned to be added?

Then can’t I activate Atmos?

I’m afraid not. It’s company policy to not provide ETAs for upcoming features. I can say, however, that it has not yet been scheduled for development.

Not in the current version of our UE4 integration, no.

Thank you for your answer.
Please check if what I understand is correct.
Are you saying that there is no way to activate ATMOS through FMOD in UE4 now?

Yes, that is indeed what I am saying: Our UE4 integration does not yet support Atmos.

Thank you, Joseph.
It was solved thanks to you.