FMOD Audio Quieter on iOS?


(Alec Brady) #1

We’ve been having an issue where the master output audio is much quieter when running on iOS devices versus Android. It is of a magnitude of around 6dB difference.

Has anyone else experienced this or know a fix?

All works fine when previewing in engine or working in FMOD Studio.
I have tested with a number of different Apple phones and tablets, all with the same result.


(リチャード清水) #2

Hi Alec,

I’ve done a few tests and actually found the iOS to be a bit louder than Androids when using the same play_sound example project.

Is the 6dB difference something that you measured with Live Update or just from the actual output from the respective phones? Some phones have a feature that soft-block users from raising the volume too high - perhaps you’ve ran into this?

Thanks,
Richard


(Alec Brady) #3

Hey there Richard,

I have verified that the soft-block feature was disabled. We’ve gone through most of the settings accessible through iOS and Unity and have found nothing which indicates an issue.


(リチャード清水) #4

Hi Alec,

Could you try building a Unity project that does not use the FMOD integration and see if you’re experiencing the same issue?

Also, check to see if you have “Prepare iOS for Recording” checked in Player Settings > Other Settings. Make sure this is unchecked.

Thanks,
Richard


(リチャード清水) #5

Hi Alec,

Did you have a chance to build a non-FMOD based Unity project? Did you see similar differences in audio levels?

Thanks,
Richard


(Alec Brady) #6

Hey Richard,

We looked at the “Prepare iOS for Recording” setting and it is unchecked.

I don’t believe we will have time to build without FMOD and setup assets and such to test. I will add a note to try it if there’s time.

Are there any other settings or options we can look for?

Thanks


(リチャード清水) #7

Hi Alec,

No other settings seem to come to mind, at least from the FMOD side. It would be best to ask this question on the Unity forums to see if they have anything.

FMOD doesn’t do anything platform specific with the output, so it is likely an OS or Unity issue. Unfortunately I can’t provide much more assistance, sorry.

Thanks,
Richard