No audio playing on IOS Issue

Hi, FMOD works well on all platforms, but on iOS, no audio is being played. I’ve already tried using this line of code that I saw in another topic: FMODUnity.RuntimeManager.CoreSystem.mixerResume() . Xcode doesn’t show any errors. Do you have any other ideas I should try?


What version of the FMOD integration are you using?

A few things to confirm:
Can you please set the following settings:
and share the logs when running the app on an IOS device.

Also, confirm that you have a Mobile bank set up in the FMOD Studio preferences:

hi thanks for reply!

update in this is that at the end for some reason the sound was being played on iphone’s notifications volume, so if this is toggle, no sound will be heard:

so, is there a way to switch the output to sound in the multimedia output instead of notification volume?

Thanks for the information.

This is an issue with the AVAudioSessionCategory Unity uses by default.

A solution is creating a callback to change the AVAudioSessionCategory to AVAudioSessionCategoryPlayback.

Let me know if you need assistance implementing the callback.

Hi @Connor_FMOD thanks for reply again, yes it would be nice if you help me implementing the callback, I’m currently using unity

No worries, you can piggyback on our callback in the file:

AVAudioSession *session = [AVAudioSession sharedInstance];
[session setCategory:AVAudioSessionCategoryPlayback error:nil];

to the line below 17:

Hope this helps!

@Connor_FMOD i tried but the result is the same, anything other idea for what could it be the issue?

Would it be possible to get a copy of your project or a stripped-down version displaying the issue uploaded to your profile to test on my side? Please note you must register a project with us before uploading files.

Hi @Connor_FMOD unfortunely the publisher does not want to share the repository, if you want information or some logs I can provide it