FMOD Debug autocomplete problem in Rider

When I type Debug in Rider the autocomplete always has (FMOD) Debug as top result rather than Unity’s Debug, this is incredibly annoying, is there any to fix this?

I haven’t tested VS2022 so it might be an issue there as well.

Unfortunately, this is an issue with your IDE and not with FMOD, and as such falls outside the scope of forum support. I would recommend checking your IDE settings and/or the Rider support forums to see whether there is an option that allows you to preference Unity.Debug.

That said, I have run into a similar issue to what you’re describing in VS, when both root namespaces are used with the using directive - i.e. both using FMOD; and using UnityEngine; are included at the top of the file. If this is the case, you may want to try modifying the using directives so that only one Debug namespace is immediately accessible, and the other has to use fully qualified name.