Can't find Fmod namespace/library in Visual studio

Not much to elaborate on, all the FMOD functions and calls in Visual Studio is unrecognized, although they seem to function in engine.


Unfortunately, it’s difficult to diagnose your issue exactly. Do any of following actions fix the issue?

  • Restarting Visual Studio
  • Reimporting the FMOD Unity Integration
  • Updating the Visual Studio Editor package from the Package Manager
  • Regenerating your .csproj files from Preferences → External Tools

If not, are you running into any other error messages in Unity or Visual Studio? Is it only FMOD that Intellisense that isn’t working for, or is it broken for Unity in general?

I shall look at all this later today when I get to the project computer. As of now I can say that I do get a “Settings instance has not been initialized. Unable to continue build.” warning, wich dissapear after pressing play the first time. I believe this is a known problem and that there’s a fix for it, but I have not modified that code yet, as I’m not entirely comfortable modifying fmods base code and functionalities, but it would appear this might be advisable. Otherwise it would seem most if not all FMod functions do work in unity. (Including c# scripts) So it would appear that it’s only visual studio wich doesn’t recognise the existence of FMod. Simply restarting VS or trying to update it’s tools and features does not work.

none of the above appears to work, no.

The settings instance initialization error should be unrelated. Can you confirm a few things for me:

  • Is FMODUnity visible in the Solution Explorer window for the project in Visual Studio?
  • Does Intellisense work fine for Unity namespaces and functions?
  • Do you still run into the issue in a fresh Unity project?

Additionally, can I get your Visual Studio, Unity, and FMOD Integration versions?

It appears to be project specific, A.I. it works with a new project. yes, unity namespaces works just fine.
versions are VS 2022 (17.4.33213) and 2019 (16.11.33214) both tried. unity version is 2021.3.16.f1. Fmod is the latest version available. 2.02.11.

Unfortunately I still haven’t been able to reproduce your issue - it doesn’t seem to be an issue with the FMOD Integration, so there’s a limit to how much I’m able to help you. You may have more luck fixing your problem by asking about it in the relevant Unity and/or Visual Studio forum. For one last potential solution though, try closing Unity and Visual Studio, deleting your project’s ./Library folder, and reopening.

The “solution” I made use of was to copy over all the files, excluding the FMod files, to a new project where I’ve installed FMod and connected it to the same library. This worked fine since it was a smaller project, and I suspect doing this with larger projects with more external dependencies would be significantly more difficult. One last note is that this was a Git project wich had FMod installed after the project was pulled. It was initially from another computer on wich it did not have FMod. This is no longer a problem for me ofcorse, but maybe it’s relevant for further inquiries and/or development of FMod.

1 Like

Thanks for sharing, it’s good to hear that you’ve resolved the issue.