FMOD is not installable on Pop_OS / Ubuntu 22.04

Unless I’m missing something, it appears FMOD depends on the libssl1.1 package, which has since been deprecated and replaced with libssl3. This makes the application unable to install, unless forcing install of the libssl1.1 package.

The pulseaudio package has also been widely replaced by pipewire and should be replaced.


1 Like

Unfortunately we restricted by our dependencies regarding the version of OpenSSL we use. That said our OpenSSL dependency should be resolved locally within the installer package and I can see that it isn’t. We will fix this up and remove the unintended system dependency on Linux.

Regarding pipewire, we don’t currently have a native implementation for it, however we’ve had good success with pipewire-pulse as a bridge connecting our pulse audio implementation with a platform pipewire server. I recommend you install that until we have a native solution.

1 Like

Awesome, thank you guys! I was able to install it and get things working, by working around these errors for now. Looking forward to the update.

1 Like

This has been fixed in 2.02.09 which is available on the Downloads page.

I still get the same error with 2.02.12 on ubuntu 22.04. (installing from the .deb)
AppImage works.

Thanks, we believe this is an out-of-date dependency listed in our installer manifest as the actual dependency issue was fixed in 2.02.09. We are looking to get this fixed for an upcoming release.