FMOD Reverb is panning left

I’m having some issues in FMOD Studio 2.02.09 where the wet signal on both the algorithmic reverb and convolution reverb are being panned slightly to the left. In the standard reverb it seems more obvious in the early reflections, and in convolution it is also in the tail. I’ve tested as both insert and send with no changes. It becomes more obvious I think at shorter reverb times. We have an underwater snapshot that uses a wet reverb signal (no pun intended) and it’s obvious that everything is getting panned left. I’ve tried testing with a fresh project and events and get the same thing. Has this been reported as a bug already? I haven’t seen anything when searching the forum.
Thank you!

Hi Tom,

Thanks for your bug report - I’ve been able to reproduce a mild difference in panning at the primarily the beginning of the wet signal. Just to confirm a few things:

  • Is this the behavior you’re experiencing as well? Or are you observing harder/full panning to the left?
  • How many channels/what speaker mode is the signal running into the reverb using?
  • How many channels/what speaker mode is your event outputting?

Hi Louis, thanks for responding!

  • Yes that’s what I’m experiencing, it’s subtle and not a hard pan
  • Everything is set to the defaults of 5.1, so with reverb on the mixer return it’s 5.1 both in and out
  • Events are all outputting 5.1 with Stereo in

I noticed it still happens when I put reverb directly on the event so it’s stereo into the reverb and the event outputs to 5.1.

I’m currently mixing on headphones/monitors so maybe that’s part of the problem.

Thanks for the additional information. Unfortunately, I haven’t been able to identify a workaround for you, but I’ve passed this along to the development team for further investigation.

I appreciate that. Thanks, Louis!

1 Like

Upon further investigation, it appears that the behavior of the algorithmic reverb is due to how it utilizes mono delay lines to create the effect (the leftmost channel will play the most recent delay line). This is expected, as it is not a true multi-channel reverb effect, and this is unlikely to be changed at this time. If you’re willing to sacrifice the stereo image of your wet signal, collapsing the pre-reverb signal to mono using an FMOD panner or by right clicking on the input meter and choosing the mono format will cause the reverb to output in mono, which you can upmix using the same method (output meter/FMOD panner).

However, I have been able to confirm that the convolution reverb does not appear to have this issue, and if you can take the increased CPU overhead, I would recommend using it for this specific use-case. It’s possible that the impulse response you are testing with is stereo, and is introducing a difference between the channels on your end, which would explain the behavior you’re observing. If this is not the case, can I get you to upload your FMOD Studio project where this is occurring, or a stripped-down project where you can reproduce the behavior, to the “Uploads” tab of your FMOD Profile?

1 Like

I’ll try these options and give an update next week!