FMOD Stops building when upgrading from 4.12.4 to 4.12.5

Hey FMOD-friends.
Once I finally got FMOD to cook our game, I had to upgrade to 4.12.5 and the party starts all over again.
This time, it can’t find files that are clearly there.
Here’s a screenshot:

I also have trouble cooking on Mac (much more so) but I’ll post that in a separate thread.

Update: It’s able to package and cook when the FMODStudio folder in Plugins is checked out in Source Control.
Without it, FMOD doesn’t seem to have access to the .lib file.
So, if those files (I did the whole folder just to make sure) aren’t checked out, it won’t run.

I’m curious to know why only FMOD fails to build when not checked out, but at least for now it works.

Another interesting error:
In the packaged file directory, the /Content/FMOD folder doesn’t exist. You can run the game but there will be no sound. I had to manually copy the /Content/FMOD folder to the exported game, and then the sound worked. This doesn’t seem to happen automatically.

UE4 will rebuild the plugin automatically if it thinks it needs to, which includes if the engine version is different and possibly if the minor patch version is different. If UE4 decides the rebuild the plugin then those files will need to be writable, otherwise you will get that error.

There are a few ways to do it, one is to check it out, let it build, and check it in. Another is to mark the files as writable even when not checked out in P4.

Ah, that makes a lot of sense, thanks! I understand it now.
Lastly, what about moving the FMOD folder to the build, is it possible to do this automatically? I already know I’m going to ship a build without audio due to forgetting to copy it manually… haha!

If you mean the banks in Content/FMOD, you can add the directory to packaging settings to make sure it is copied over automatically. See this page for more info: